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1 DESCRIPTION 

Contained in this document are details concerning the standard operating procedure (SOP) for 

collecting, processing, and producing Level 4 bathymetric and habitat maps at NEON aquatic lake and 

non-wadeable river sites. Specifically, the processes necessary to convert “raw” electronic survey data 

and field measurements into Level 4 spatial data products and their associated uncertainties are 

described. These data are collected using a boat-mounted system applied during manned surveys of 

NEON lakes and river sites. A Biosonics MX, single beam, down looking echo sounder and GPS are used 

to collect backscatter (signal strength) data. Sonar timeseries are converted into depth contour lines for 

the development of a bathymetric map (Figure 1a) and a habitat map (Figure 1b). Data is collected using 

the Visual Acquisition software and processed using the Visual Aquatic software, which are both freely 

available from the www.biosonicsinc.com website. Bathymetric surveys are completed at least every 5 

years; if an extreme event results in substantial changes to the physical environment then an out-of-

cycle survey may be requested. 

 

Figure 1. Example bathymetric map (a) and a classified habitat map (b). 

1.1 Purpose 

This document details how to create NEON Level 4 data products for bathymetric and habitat maps from 

Level 0 data, and how to organize ancillary data obtained via instrumental measurements using steps 

outlined in the AOS Protocol and Procedure: Bathymetry and Morphology of Lakes and Non-Wadeable 

Streams (RD[04]). It includes a description of the field data collection procedures, appropriate 

background information, an itemized list of data products, quality assurance and control methods used, 

and approximations and/or assumptions made for the collection of data used to create the bathymetric 

and habitat maps.  

1.2 Scope 

This document provides a change-controlled version of an Observatory procedure. Documentation of 

content changes (i.e. changes in particular tasks or safety practices) will occur via this change-controlled 

document, not through field manuals or training materials. 

http://www.biosonicsinc.com/
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1.3 Applies To 

This document describes how to derive Level 4 data from Level 0 data for the AOS Protocol and 

Procedure: Bathymetry and Morphology of Lakes and Non-Wadeable Streams (RD[04]). It does not 

provide computational implementation details, except for cases where these stem directly from SOP 

choices and assumptions explained here. 

1.4 Acknowledgments 

N/A 
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2 RELATED DOCUMENTS AND ACRONYMS 

2.1 Applicable Documents 

Applicable documents contain higher-level information that is implemented in the current document. 

Examples include designs, plans, or standards.  

AD[01] NEON.DOC.000001          NEON OBSERVATORY DESIGN 

AD[02] NEON.DOC.005003          NEON Scientific Data Products Catalog 

AD[03] NEON.DOC.002652          NEON Data Products Catalog 

AD[04] NEON.DOC.004104          NEON Science Data Quality Plan 

AD[05] NEON.DOC.005001          NEON Coordinate Systems Specification 

AD[06] NEON.DOC.050005 Field Operations Job Instruction Training Plan 
1 Note that CI obtains calibration and sensor values directly from an XML file maintained and updated by CVAL in 

real time. This report is updated approximately quarterly, so there may be a lag time between the XML and report 
updates.   

2.2 Reference Documents 

Reference documents contain information that supports or complements the current document. 

Examples include related protocols, datasheets, or general-information references.  

RD[01] NEON.DOC.000008 NEON Acronym List 

RD[02] NEON.DOC.000243 NEON Glossary of Terms 

RD[03] NEON.DOC.002652 NEON Data Products Catalog 

RD[04] NEON.DOC.001197 AOS Protocol and Procedure: BAT – Bathymetry and Morphology of 
Lakes and Non-Wadeable Streams 

RD[05] NEON.DOC.003104 Datasheets for AOS Protocol and Procedure: Bathymetry and 
Morphology of Lakes and Non-Wadeable Streams 

RD[06] NEON.DOC.004857 NEON Standard Operating Procedure: Post-processing of Wadeable 
Stream Morphology Data from NEON Wadeable Streams 

RD[07] NEON.DOC.005221 AOS/TOS Standard Operating Procedure: Trimble GeoXH Receivers 
Setup and Use  

RD[08] DP4.00132.001 NEON User Guide to Bathymetric and Morphological Maps  

2.3 External References 

ED[01] Heyman, W.D., J-L. B. Ecochard, and F.B. Biasi. 2007. Low-cost bathymetric mapping for 
tropical marine conservation – A focus on reef fish spawning aggregation sites. Marine 
Geology, 30: 37-50 

ED[02] Visual Aquatic User Guide: Post-Processing and Data Visualization Software for BioSonics 
Echosounder Systems: V1.0. BioSonics, Inc. Seattle, WA.  

2.4 Acronyms 

Acronym Definition 

DGPS Differential Global Positioning System 
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DP Data Product 

EBK Empirical Bayesian Kriging 

L4 Level 4  

GCS Geographic Coordinate System 

GIS Geographic Information System 

GPS Global Positioning System 

MODIS Moderate Resolution Imaging Spectroradiometer 

NDVI Normalized Difference Vegetation Index 

PCS Projected Coordinate System 

SOP Standard Operating Procedure 

UTM Universal Transverse Mercator 

VA Visual Aquatic 

WAAS Wide Area Augmentation System 

WGS World Geodetic System 

2.5 Definitions 

N/A 

2.6 Spatial File Types and Extensions 

2.6.1 Shapefile 

Extension Explanation 

.shp 
The main file that stores the geometry of a feature as a series of vertices (e.g. point, 
line, polygon) 

.shx The index file that stores the position of the feature geometry 

.dbf 
The dBASE table file stores the attribute information of the features and maintains a 
one-to-one relationship between geometry and attributes based on record number  

.prj 
The projections definition file stores geographic coordinate and projection system 
information 

.xml 
Extensible Markup Language file contains metadata associated with the file and can be 
viewed in a text editor 

.sbn Spatial index file for optimizing spatial queries (when used in conjunction with .sbx) 

.sbx 
Spatial index file for optimizing loading time of spatial queries (when used in 
conjunction with .sbn) 

.cpg Encoded plain text file describes shapefile text character set 

2.6.2 Image File 

Extension Explanation 

.tif Tagged Image File format stores an array of pixels to form a high-quality raster graphic 

.tfw 
World File for TIF contains the location, scale, and rotation of the data that is stored as 
a .tif image for geographic reference 



 

Title: AOS Standard Operating Procedure: BAT – Post-Processing of Bathymetric and Side 
Scan Sonar Data from NEON Lakes and Non-Wadeable Streams 

Date: 06/22/2023 

NEON Doc. #: NEON.DOC.004856 Author: B. Jensen Revision: D 

 

 

Page 5 

2.6.3 Earth Viewer File 

Extension Explanation 

.kml(z) 
Keyhole Markup Language file is an xml format extension for visualizing geographic data 
in an internet-based geobrowser like Google Earth    

2.6.4 Sonar File 

Extension Explanation 

.dt4 File format used for processing data by Visual Acquisition 

.rtpx 
File format used when collecting data with the Biosonics MX unit, can be converted to 
.dt4 using the utilities in Visual Acquisition 

2.6.5 Trimble GPS File 

Extension Explanation 

.ssf Data file used by Trimble GIS mapping software applications to log GPS data  
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3 PERSONNEL 

3.1 Training Requirements 

All technicians must complete protocol-specific training as required in the Field Operations Job 

Instruction Training Plan (AD[06]). Additional protocol-specific required skills and safety training are 

described here. 

3.2 Specialized Skills 

Use BioSonics and arcMap or arcPro software to process field data.   
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4 DATA PRODUCT DESCRIPTION 

4.1 Variables Reported 

The Bathymetry and Morphology of Lakes and Non-Wadeable Streams (RD[04]) and related L4 DPs 

provided by the procedures documented in this SOP are displayed in the accompanying file NEON Data 

Variables for Bathymetric and Morphological Maps (NEON.DP4.00132). A summary of the L4 DPs 

associated with this SOP are detailed in the following table.  

Table 1. Metadata for L4 Data Products Associated with the Bathymetric (BATH) and Habitat (HAB) Map with 
Estimated File Sizes and Descriptions. 

File Type File Size Range Description 

BATH_contour.shp 70 kb – 300 kb Shapefile format containing vector data of contour 
depth lines at a specific interval.  

BATH_shorePolygon.shp 
and BATH_shoreline.shp 

100 kb Line and polygon shapefile format containing 
vector data of the closed boundary around the 
shoreline. 

BATH_tracks.csv 500 – 1,000 mb 

Table containing the spatial data for each sonar 
ping group (longitude, latitude, depth, time) as well 
as the raw exports from the bottom elevation, 
plant height, plant coverage, and bottom type 
analyses. 

BATH_volume.csv < 1,000 kb 
Table containing water volume calculation, 2D area 
(flat surface), and 3D area (sum of surface area) 
calculations at successive depths.  

BATH GE.kmz 300 kb – 2,700 kb 
Earth Viewer file of derived bathymetric map 
viewable in Google Earth.  

BATH_Map.pdf 400 kb – 1,300 kb 
Portable document format for viewing derived 
bathymetric map.  

BATH.tif 1,000-1,700 kb Image file of interpolated depths. 

HABITAT.shp  40 - 300 kb Shapefile format of classified habitat features 
derived as polygons. 

HABITAT_area.csv < 500 kb Table containing unique fields for each habitat 
classification and total area of each classification  

PLANT.shp 40 - 300 kb Shapefile format of the binned plant coverage 
features derived as polygons. 

PLANT_area.csv < 500 kb Table containing unique fields for each plant cover 
bin and total area of each classification  

HABITAT_GE.kmz 150 - 170 kb 
Earth Viewer file of derived habitat map viewable 
in Google Earth.  

HABITAT_Map.pdf 156 – 350 kb 
Portable document format for viewing derived 
habitat map.  

VAdataset.vhmcfg and 
VAdatasset_AnalysisResults 
Folder 

100-200 kb 
Processed sonar data and the necessary accessory 
files to open the .vhmcfg file in Visual Aquatics 
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4.2 Input Dependencies 

Input dependencies provided in Table 2. 

Table 2. List of the equipment used to collect L0 DPs that are transformed into L4 DPs in this SOP. 

Description Sample Frequency Units Data Product Number 

Biosonics MX Habitat Echosounder  1  

Trimble GPS GEO XH 6000 or 7000 1 Hz; decimeter (10 cm/4 
inch) accuracy positioning 

1 DP1.20086.001 

4.3 Product Instances 

The equipment will be deployed to collect input variables at NEON lake and river sites. Bathymetry data 

will be collected every 5 years (at minimum) during the second biological sampling bout and during the 

period of peak greenness. Peak greenness is defined as the range of dates where MODIS EVI is within 

90% of the site maximum. Lake sites include: 

• Domain 03 - SUGG and BARC  

• Domain 05 - CRAM and LIRO 

• Domain 09 - PRLA and PRPO 

• Domain 18 - TOOK 

Non-wadeable (river) sites include: 

• Domain 03 - FLNT 

• Domain 08 - BLWA and TOMB 

4.4 Temporal Resolution and Extent 

The finest temporal resolution at which bathymetric and morphological data are reported is the 

endDate, a single date on which survey data were collected. Bathymetric and morphological surveys are 

conducted at each lake and river site at least once every five years. Should an extreme event result in 

significant changes in water level, morphology, or habitat, an additional survey may be conducted 

sooner than every 5 years once safe conditions allow.  
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5 SCIENTIFIC CONTEXT 

Bathymetry and morphology are key parameters for defining the hydrological, physical, chemical, and 

biological characteristics of lakes and non-wadeable streams. Water level, volume, area, and stage curve 

relationships provide spatial quantitative information. They also impart a governing role on 

hydrodynamics, water quality, biogeochemical relationships, and biological productivity.
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6 STANDARD OPERATING PROCEDURES 

SOP A Post Processing the Raw L0 Data 

A.1 Post Processing in Visual Aquatic 

The Visual Aquatic User Guide (ER[02]) should be followed during all analyses. This document provides 

high level steps, NEON specific workflows, and additional notes. The different analysis types should be 

performed in the SOP order below.  

A.2 Required Platforms and Tools 

1. BioSonics Visual Aquatic 1.0 – free software 

2. BioSonics Visual Acquisition 6.4.1 – free software 

A.3 Creating or Opening a Dataset 

1. For new projects: 

a. Open Visual Aquatic> File>New Dataset 

b. Navigate to the workspace folder where the .dt4 and .rptx files are saved. 

i. Note: Running all BioSonics processing from a local drive results in faster 

processing times. 

c. Name and save the dataset. 

d. In VA open File>Add files to load all the .dt4 files from the survey. 

2. For existing projects: 

a. In Visual Aquatic go File>Load Dataset 
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Figure 2. Key features in the Visual Aquatic tool bar. 
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A.4 Bottom Detection Analysis 

1. Select all the records and click the Play button.  In the pop up check the “Bottom Detection” box 

and click start. 

2. Each record will need to be manually checked. For each record: 

a. Highlight the row and click the “playback” button (symbol with red line and blue dots). 

b. From the drop down menu choose “bottom detection”. 

i. The brown line is the initial result from the analysis. 

c. Smooth and correct the brown line as needed. Pings are averaged by 10 in the export 

phase so the goal is not complete accuracy but to remove any erroneous peaks or 

valleys that would greatly affect an average.  

i. Take a screenshot and made note of any instances where the sonar data looks 

strange and a targeted ground truth point is needed. Record the latitude and 

longitude from the bottom right of the screen. 

Figure 3. Before and after manually editing the bottom depth results (brown line). 
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d. If the bottom line should be less than .5m, manually draw the bottom line following the 

curve (for example, interpolating where the top of the green shading would be). Make a 

separate note of how deep the water is at those pings. Once the data is fully processed 

and exported filter where elevation depth equals 0.5 (output leaves no decimal places if 

above 0.5 compared to all the other pings) and manually update the depth with the 

values from your notes.  

e. Once the edits are complete close the file and the changes will be saved.  The record will 

now say “Manual Edit” under the “Bottom Depth” header if any edits were necessary. 

2. Complete manual checks and edits for all the records in the dataset. 

A.5 Plant Coverage Analysis 

1. Select all the records and click the “Configure Analysis” button.  

a. Click on the “Plant Detection” tab and change the “Maximum Plant Depth” to the site-

specific plant colonizable depth as captured in the NEON User Guide to Bathymetric and 

Morphological Maps (RD[08]) appendix tables and click “ok”.  

2. Click the “Play” button.  In the pop up check the “Plant Detection” box and click start. 

3. Each record will need to be manually checked. 

a. For each record highlight the row and click the “playback” button (symbol with red line 

and blue dots). 

b. From the drop-down menu choose “Plant Detection”. 

i. The green line is the initial result from the software. 

Figure 4. After manual edits to the bottom depth 
results to account for a shallow section less than 0.5m. 
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ii. Plants appear on the echogram with a visible “beard” of noise under the bottom 

depth line 

c. Smooth and correct as needed. Pings are averaged out by 10 in the export phase so the 

goal is not complete accuracy but to remove any erroneous peaks or valleys that would 

greatly affect an average.  

d. Take a screenshot and made note of any instances where the sonar data looks strange 

and a targeted ground truth point is need. Record the latitude and longitude available 

on the bottom right of the screen. 

e. Once the edits are complete close the file and the changes will be saved. The record will 

now say “Manual Edit” under the “Plant” header if any edits were necessary. 

4. Complete manual checks and edits for all the records in the dataset. 

A.6 Bottom Type Analysis 

1. Select all the records and click the “Configure Analysis” button.  

a. Click on the “Bottom Type” tab and change the “Number of clusters” to the number of 

unique bottom types identified by Field Science in the random ground truth points (see 

the associated Fulcrum data). 

2. Click the “Play” button. In the pop up check the “Feature Extraction” and “Bottom Type” boxes 

and click start. 

3. Follow the gridding analysis steps below to grid and export the map. 

Figure 5. Examples of plants, the "beard", and microbubbles 
from a wake in the echogram. Taken from ER[2]. 
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4. Re-run with plus and minus 1 cluster from the original run.  

a. Open the “Run Analysis” and click “view/change bottom type clusters…” for faster 

analysis. 

b. Note: the previous analysis is overrun each time so be sure to export before re-running 

the bottom type analysis with a new number of clusters. 

A.7 Gridding Analysis 

The gridding analysis is used to for both plant coverage and bottom type.   

1. Select all the records and go View>Show Map View. 

2. Change the coordinate system.  

a.  Map View> Base Map Properties 

b. Choose WGS84 and the UTM projection for the site. 

i. Tip- if nothing shows up on the map first check that the “data points” under 

“layer opacity” is greater than 0%.  

3. In map view zoom in and measure the distance between 3 random data points. Record the 

smallest. 

4. Under “Grid Tool” select “Gridding/Contouring”. 

a. Check either “Plant Height, Coverage” or “Bottom Type” under “Create Grids”.  

b. Start with a grid cell size of “1”. For larger sites this may need to be increased if the 

export becomes too large to load or manipulate in ArcMap. 

5. Choose “Kriging” from the drop down and hit the “…” to change the settings.  

6. Follow the instructions for the kriging gridding in the VA user guide (ER[2]). Below are the 

variables that should be adjusted for each run. 

a. Distance Bin Size:  

i. Enter the point distance that was recorded in step 3. 

ii. Hit “Compute” and look at the “Error” in the Model Box. 

1. Keep increasing by 1 and re-computing until the best variogram fit and 

lowest error is determined. 

2. Following the VA user guide example, “4” is typically used. 

b. Variogram modeling: 

i. Highlight each row and click the automatic optimization for “type, range, 

nugget, sill”. 
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ii. All variogram memberships should use the same type, manually change if one is 

different. 

7. Click “OK” and then “Start”. 

8. Once the gridding is complete check the map view to see the output. 

a. Under Map>Configure choose the correct “Map View Data Type” from the drop down. 

b. Change the number of colors to match the number of clusters for the bottom type 

output or the number of plant coverage bins you want to see in the output. 

9. View the map. Change the “Gridded Data” to 100% in the “Layer Opacity” screen. 

10. For bottom type grids: 

a. If the map contains unique clusters and not just a few scattered pixels then export the 

map.  If unsure, err on exporting the map. See the example in the figure below. 

 

 

 

 

 

 

 

 

 

 

 

 

A.8 Exporting Files 

Note:  For all file names “surveyDate” should be the last date sonar data was collected in YYYYMMDD 

format.  

1. To export the bottom depth results and create the tracks.csv: 

A: Two Clusters B: Three Clusters C: Four Clusters 

Figure 6. Map of three different outputs for gridded bottom types. In map A 
the polygons are well defined, and this result should be exported. Map B has 
some pixilation occurring, but since 3 clusters matches the number of unique 
bottom types in the random ground truth points this map should be exported 
as well. In Map C, the fourth bottom type, in red, does not have well defined 
polygons and the map should not be exported. 
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a. Check parameters: 

i. Under “View” go to “Map View”. 

ii. Go Map>Configure 

1. Report interval should be 10 pings. 

2. Under “Plant Depth” plant “Height Threshold” should be 0.05m. 

b. On the main screen click the export symbol (letter with the arrow). 

c. Click all the boxes under the “CSV Export” window and change the filename to: 

“DXX_SITE_BATH_surveyDate_tracks.csv”. 

d. Click “Start”. 

e. The .csv will be exported to the VA analysis folder. 

2. To export the gridded maps: 

a. In Map View >Grid Tools> Export 

b. Click the map type and then shapefile and gird cells. 

c. Include the number of clusters used in the output file name. 

d. The shapefiles will be exported to the VA analysis folder. 

3. To export marked events: 

a. Open Visual Acquisition. 

b. Go to Utilities<File Utilities  

i. Input File Type is “RTPX”. 

ii. Choose Export Data to CSV Files and click the “…”. 

iii. Select “Mark Event” and make sure the Lat/Long/ and Comment fields are 

checked. 

iv. Click Ok. 

v. Click Process Files and browse to the rtpx files that contain marked events. 

vi. Select all and hit “open”. 

c. Run the code below in R to combine all the outputs into a single .csv. 

folder <- ''  # path to folder that holds multiple marked event .csv files 

file_list <- list.files(path=folder, pattern="*.csv")  #only add files with .csv ending 

#merge all into one dataframe 

data <-  
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    do.call("rbind",  

            lapply(file_list,  

                   function(x)  

                       read.csv(paste(folder, x, sep=''),  

                                stringsAsFactors = FALSE)))      

write.csv(data, paste(folder, 'combinedMarkedEvents.csv', sep= ""),row.names = F)  
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SOP B Post Processing in GPS Pathfinder Office 

All the .ssf files in L0 data folder will need to be postprocessed in GPS Pathfinder Office and exported to 

a shapefile format.   

B.1 Required Platforms and Tools 

1. Trimble GPS Pathfinder Office version 5.85 

B.2 Differential Correction 

1. Open GPS Pathfinder Office.  

2. Follow SOP B.1 in NEON.DOC.005221 (RD[07]) to set up the project and data view windows. 

3. Follow SOP G.1 – G.2 in NEON.DOC.005221 (RD[07]) to post process each .ssf file. All files can be 

post processed at the same time. 

B.3 Exporting 

1. Follow SOP G.3 in NEON.DOC.005221 (RD[07]) to export the post processed data. 

2. In step 5 select “Sample ESRI ShapefileSetup”. 

a. Be sure to export in the correct UTM zone and WGS 84 datum. 
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SOP C Post Processing in ArcMap 

The rest of the analysis and map creation steps take place in ArcMap. The instructions below are written 

for ArcGIS version 10.5 but the same overarching workflow could be used in different versions or 

different software.   

Bathymetry outputs (contours, volume amounts per elevation) are created first, followed by a plant 

coverage shapefile, and bottom type shapefiles for each cluster exported from Visual Aquatics. Random 

ground truth points collected during the sonar survey are overlayed on top of the habitat layers. 

Up to ten targeted ground truth locations are created for field teams to visit at the site and record 

bottom type and plant presence in areas where clarification is needed.  

After the targeted ground truth points have been checked in the field, the sonar outputs, ground truth 

point data, and site knowledge are used to determine which bottom type model best fits the site and 

the final L4 files are created.  

C.1 Required Platforms and Tools 

1. ArcGIS - Version 10.5+ with extensions: 

1.1. Geostatistical Analyst 

1.2. Spatial Analyst 

1.3. 3D Analyst  

2. ET Geo Wizards for ArcGIS 10.4+  

3. Google Earth 

C.2 Bathymetry 

At sites where the shoreline data is collected with a GPS receiver while walking the perimeter: 

The steps below describe how to merge the GPS data from the shoreline .ssf file with the bottom 

detection analysis from Visual Aquatic to create the bathometric outputs.  

1. Load the shoreline shapefile created in SOP B.3. 

a. If needed, set the projection the correct UTM zone, WGS 84. 

i. ArcToolbox>Data Management Tools>Projections and Transformations>Define 

projection. 

b. Update the attribute table so the only columns are: 

i. “Name”:  text field, full site name 
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ii. “Length” double field, right click and use “Calculate Geometry” to calculate the 

length in meters. 

c. If necessary dissolve the shapefile on “Name” so there is one continuous line for the 

entire shoreline. 

i. ArcToolbox>Data Management Tools>Generalization>Dissolve 

1. Dissolve_Field = “Name” 

2. “Create multipart features” should be checked. 

ii. Recalculate the “Length” field. 

d. Rename the shapefile “DXX_SITE_BATH_surveyDate_shoreline” 

2. Convert the line shapefile to a polygon shapefile.  

a. Use the ET Geowizards tool “polyline to polygon”. 

i. Save the output as DXX_SITE_BATH_surveyDate_shorePolygon. 

ii. Check the “Use closed polyline chains” and “Force Closure” boxes. 

iii. Enter “10” in the meter box. 

iv. If needed, update the attribute table so the only columns are: 

1. “Name”:  text field, full site name 

2. “Area” double field, right click and use “Calculate Geometry” to 

calculate the area in meters squared. 

v. Tip- if the created polygon does not match the line run the “Feature Vertices to 

Points” tools and the “dangle” point type to see if there are any open sections 

that you need to close. 

vi. Be sure to remove the extra “ID” column that is often created at this step.  

3. Convert the shore polygon file to a point file. 

a. ET GeoWizards Convert > Polygon to Point 

i. Select polygon layer > Shore Polygon shapefile. 

ii. Specify output feature class or shapefile > Name: “shorePoints”.  

iii. Save as type > Feature classes > Save > Next  

iv. Specify conversion option > Vertices > Finish  

b. Tip: If the shoreline polygon has a lot of straight sections and there are large spaces 

between the points after the polygon to point conversion use the arcToolbox>Data 

Management Tools >Sampling>Generate Points Along Lines to create a point every 1m.  
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4. Load the “DXX_SITE_BATH_surveyDate_tracks.csv” created in 5.1.7 into ArcMap.   

a. File> Add Data  

5. Display the xyz locations. 

a. File > Add Data > Add XY Data 

i. X Field: Longitude 

ii. Y Field: Latitude 

iii. Z Field: ElevationBottom 

iv. Coordinate System of Input Coordinates > Edit > XY Coordinate System Tab > 

Geographic Coordinate Systems > World > WGS 1984 > OK > OK > OK 

b. Note: if there are any manual edits to make to the bottom elevation values from step 3 

in section 5.1.3 now is the time to do so using the “field calculator”. 

6. Export the .csv Events file to shapefile.   

a. Right click the Events layer created in step above Data > Export Data  

i. Export: All features  

ii. Use the same coordinate system as: shoreline polygon (UTM zone XXN, WGS 84) 

iii. Output feature class: tracks   

iv. Save as type: Shapefile  

Figure 7. Map showing the track points from the sonar 
survey (maroon points) and the shoreline points (teal 
points) from the GPS file. 
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At sites where the shoreline cannot be walked: 

7. Load the “DXX_SITE_BATH_surveyDate_tracks.csv” created in 5.1.7 into ArcMap.   

a. File> Add Data  

8. Display the xyz locations. 

a. File > Add Data > Add XY Data 

i. X Field: Longitude 

ii. Y Field: Latitude 

iii. Z Field: ElevationBottom 

iv. Coordinate System of Input Coordinates > Edit > XY Coordinate System Tab > 

Geographic Coordinate Systems > World > WGS 1984 > OK > OK > OK 

b. Note: if there are any manual edits to make to the bottom elevation values from step 3 

in section 5.1.3 now is the time to do so using the “field calculator”. 

9. Export the .csv Events file to shapefile in the Workspace folder.   

a. Right click the Events layer created in step above Data > Export Data  

i. Export: All features  

ii. Use the same coordinate system as: shoreline polygon (UTM zone XXN, WGS 84) 

iii. Output feature class: tracks   

iv. Save as type: Shapefile 

10. Create a buffer around all the BioSonics track points: 

a. ArcToolbox > Analysis Tools > Proximity > Buffer 

i. Input Features: tracks 

ii. Output Feature: tracksBuffer 

iii. Distance: Unless Field Science indicates the average distance to the shore use 

3m 

iv. Dissolve Type: All 

11. Combine all the buffer polygons into one polygon: 

a. ArcToolbox > Analysis Tools >Overlay >Union 

i. Input Features: tracksBuffer 

ii. Output Feature: tracksBufferUnion 

iii. Uncheck the “Gaps Allowed” box 
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12. Dissolve the new polygons into one 

a. ArcToolbox > Data Management Tools >Generalization >Dissolve 

i. Input Features: tracksBufferUnion  

ii. Output Feature: DXX_SITE_BATH_surveyDate_shorePolygon. 

iii. Dissolve_Fields: Id 

13. Edit the polygon so it is one continuous polygon with no gaps.  

a. To edit: Right click on the layer > Edit Features > Start editing 

b. Make sure the Create Features window is open (see editing toolbar) and the correct 

layer is selected 

c. Right click in side of the layer you wish to edit > Edit vertices 

d. To delete vertices:  

i. Click the arrow with the negative sign in the Edit vertices toolbar 

ii. Highlight or click the area you wish to delete from 

e. To add vertices: 

i. Click the arrow with the positive sign in the Edit vertices toolbar 

ii. Click the area you wish to add a vertices too 

f. To move vertices: 

i. Click the arrow with the in the Edit vertices toolbar 

ii. Click vertices you want to move and move it 

14. If necessary, smooth edges and adjust the polygon to match the real shoreline as seen in aerial 

imagery. This should only be down to edit large areas (the other side of an island, a large area 

that the boat could not go over) and should not be used to “fine tune” point by point.    

a. Go to the Editor Toolbar>Save Edits and then Edit >Stop Editing to save your edits 
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Figure 8. Image demonstrating smoothing large areas to match the shoreline. In the before image (left) the blue 
shoreline polygon only covered one side of the island and had a large space along the right bank due to the track 
data (grey points) locations. The after image (right) now has the shoreline boundary following the imagery in both 
locations.  

15. If a river- edit the ends to include all the tracks and have a “straight” edge. See figure below.  

16. Edit the attribute table so there are two columns:  

a. “Name”:  text field, full site name 

b. “Area” double field, right click and use “Calculate Geometry” to calculate the area in 

meters squared. 

Figure 9. Image illustrating how to edit the upstream and downstream ends of a river site. 
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17. Create the shoreline line file: 

a. Toolbox> Data Management> Features > Feature to Line 

b. “DXX_SITE_BATH_surveyDate_shoreline” 

c. Remove the “Area” field and add a “Length” double field 

d. Use calculate geometry to add the length in meters 

e. Remove any extra fields that were created during processing 

18. Create a points file: 

a. Toolbox> Data Management> Features > Feature Vertices to Point 

b. Output > shorePoints 

c. Point Type > All 

For all processing: 

19. If a river site, remove the “short end” points so only points along the actual shore (“long ends”) 

remain.   

 

Figure 10. Removing all points not along the shore bank so points withing the river are not assigned an elevation of 
zero. 

 

20. Merge all the point files together. 

a. ArcToolbox > Data Management Tools > General > Merge 

i. Selection Expression: 



 

Title: AOS Standard Operating Procedure: BAT – Post-Processing of Bathymetric and Side 
Scan Sonar Data from NEON Lakes and Non-Wadeable Streams 

Date: 06/22/2023 

NEON Doc. #: NEON.DOC.004856 Author: B. Jensen Revision: D 

 

SOP C 
 

Page 26 

1. Input Datasets: tracks, shorePoints, and if created, the output from 

“Generate Points Along Lines” 

2. Output data: tracksShorePointsMerge 

3. Field Map, remove all fields except: “Longitude”, “Latitude”, and 

“BottomElev” 

a. Environments… 

i. Outpoint Coordinates to match site specific UTM 

coordinate system 

21. Make sure the elevation for all the shoreline points is “0”. 

a. Open “trackShorePointsMerge” attribute table and make sure all rows without lat/long 

values (the shorepoints) have a bottomeElev of “0”.  

22. Interpolate the data using Bayesian Kriging.  

a.  ArcToolbox > Geostatistical Analyst Tools > Interpolation > Empirical Bayesian Kriging 

i. Selection Expression:  

1. Input features: tracksShorePointsMerge  

2. Z value field: BottomElev  

3. Output geostatistical layer: optional  

4. Output raster: “SiteID_EBK.tif”  

5. Output cell: 1  

6. Data transformation type: EMPIRICAL  

7. Semivariogram model type: K_Bessel 

a. Environments… 

i. Raster Analysis 

1. Cell Size: Maximum of Inputs  

2. Mask: Lake Shore Polygon  

ii. Output Coordinates 

1. Output Coordinate System  

a. As Specified Below: WGS 9184 UTM 

Zone xN > OK>OK 

23. Create the Isobath contour lines (depth contour lines at specified increments). 

a. ArcToolbox > 3D Analyst Tools > Raster Surface > Contour 
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i. Selection Expression: 

1. Input raster: SiteID_EBK.tif 

2. Output polyline features: contour 

3. Contour interval: dependent on lake depth 

a. 0.5m contour for up to 5m depth 

b. 1m contour for up to 10m depth  

c. 2m contour for greater than 10m depth  

4. Base contour: 0  

5. Z factor: 1  

b. Note- the final shapefile attribute name is “Contour” not “CONTOUR”.  Manually edit if 

necessary. 

24. Define the surface volume. 

a. ArcToolbox > 3D Analyst Tools > Functional Surface > Surface Volume 

i. Selection Expression:  

1. Input Surface: SiteID_EBK.tif  

2. Output Text File: volume.txt 

3. Reference Plane: ABOVE if values are positive; BELOW if values are 

negative.  For lake bathymetry, select BELOW 

4. Plane Height: 0 

5. Z Factor: 1  

ii. Repeat step with total number of isobaths displayed and merge all surface 

volumes into one file. 

1. Change the Plane Height for each iteration by the number of 

graduations used for the contour lines identified in step 10.3 (0, -1, -2, -

3 or 0, -2, -4, -6, etc). 

25. Update the symbology for map visualization  

a. SiteID_EBK 

i.  Right click raster in Layers Table of Contents > Properties > Symbology tab  

1. Show > Classified 

a. Classification Method = Defined Interval (identified in step 10.3) 

> OK  
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b. Color Ramp  

i. Right click to uncheck Graphic View 

1. Select Prediction > OK 

C.3 Plant Coverage 

The plant coverage shapefile output from Visual Aquatic contains a percent cover value for each cell.  

The file is often large and takes a while to load. The plant coverage values are then assigned to a density 

bin and the shapefile is dissolved based on the bin values to create a more manageable layer.  

1. In ArcMap, add the plant coverage shapefile created in Visual Aquatic.  

2. Open the attribute table and create a new text column called “Bin”. 

3. Right click on the new column and open the “Field Calculator”. 

a. Make sure “VB Script” is selected in the Parser. 

b. Click “Show Codeblock” and paste the script below in the box: 

Dim density 

If [Z] < 10 Then 

Bin = "0-10% " 

elseif [Z] < 25 Then 

Bin = "10-25% " 

elseif [Z] < 75 Then 

Bin = "25-75%" 

else 

Bin = "> 75% " 

end if 

c. In the second box: Bin = Bin  

Figure 11. Bathymetry map before and after changing the symbology. 
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d.  Press “OK” 

 

4. Dissolve the plant coverage shapefile by “Bin”. 

a. ArcToolbox>Data Management Tools>Generalization>Dissolve 

i. Dissolve_Field = “Bin” 

ii. “Create multipart features” should be checked 

iii. New shapefile name is “DXX_SITE_PLANT_SurveyDate” 

iv. Make sure the only fields are “Bin” and create an “Area_m2” field. 

v. Recalculate the polygon area using the “Calculate Geometry” rule.  

5. If necessary use ArcToolbox>Analysis>Overlay>Erase to remove plant coverage from areas 

below the maximum plant depth. 

a. When gridding the sonar transect data to create a continuous estimate of cover often 

some plant cover shows up below the max depth values. 

6. If necessary, clip the final shapefile to the shorepolygon.   Often the gridding step extends the 

layer paste the shoreline.  

7. Open the .dbf in excel and save as .csv with the name “DXX_SITE_PLANT_SurveyDate_area.csv” 

 

Figure 12. Field calculator codeblack to assign plant 
coverage values to density bins. 



 

Title: AOS Standard Operating Procedure: BAT – Post-Processing of Bathymetric and Side 
Scan Sonar Data from NEON Lakes and Non-Wadeable Streams 

Date: 06/22/2023 

NEON Doc. #: NEON.DOC.004856 Author: B. Jensen Revision: D 

 

SOP C 
 

Page 30 

C.4 Bottom Type 

In the bottom type shapefile output from Visual Aquatic each cell is assigned a bottom type value (1-3 

for a 3 cluster output, 1-4 for a 4 cluster output, etc).  Repeat the steps below for each bottom type 

shapefile exported from Visual Aquatics. 

1. In ArcMap, add the bottom type shapefile created in Visual Aquatic.  

2. Dissolve the shapefile by “Z” 

a. ArcToolbox>Data Management Tools>Generalization>Dissolve 

b. Dissolve_Field = “Z” 

c. The output file name should contain the number of clusters in the shapefile 

d. “Create multipart features” should be checked 

C.5 Random Ground Truth Points and Marked Events 

Transform the random ground truth points (from the fulcrum data) and marked events (from the .rptx 

data) .csvs to shapefiles. Repeat the steps below for each file type. 

1. Load the csv file in ArcMap. 

a. File> Add Data  

2. Display the xyz locations. 

a. File > Add Data > Add XY Data 

i. X Field: Longitude 

ii. Y Field: Latitude 

iii. Z Field: ElevationBottom 

iv. Coordinate System of Input Coordinates > Edit > XY Coordinate System Tab > 

Geographic Coordinate Systems > World > WGS 1984 > OK > OK > OK 

3. Export the .csv Events file to a shapefile. 

a. Right click the Events layer and use Data > Export Data  

i. Export: All features  

ii. Use the same coordinate system as: shoreline polygon (UTM zone XXN, WGS 84) 

iii. Output feature class: either “markedEvents” or “randomGroundTruthPoints” 

iv. Save as type: Shapefile 
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C.6 Creating the Habitat Map and Targeted Ground Truth Points

Once all the layers have been created multiple maps are created and compared to one another to 

determine what number of bottom types best fit the site. 

1. Open ArcMap 

2. Add the following shapefiles created in the steps above and change the symbology to best suit 

each file type: 

a. Contour lines 

b. Plant coverage 

c. Bottom type from each cluster analysis 

d. markedEvents 

e. randomGroundTruthPoints 

f. Any additional shapefiles created in the GPS Pathfinder Office export 

i. For example, some sites will have GPS data for large woody debris or emergent 

vegetation in areas that were too shallow to drive the boat over. 

3. Click the various bottom type layers on and off ask the following questions: 

• Which bottom type output matches up best with the random ground truth data? 

• Does the bottom type polygons make sense with the contours of the lake or river? 

o For example- at river sites there are often clay shelves along the banks that then 

drop off in the middle, deeper channels.   

• Does the bottom type polygons make sense with the plant coverage areas? 

• Does it make sense to combine bottom types based on ground truth data? 

Some habitat maps are easy to determine. The ground truth points match up perfectly with one of the 

bottom type exports.  Other times there are disagreements between the datasets and it is not as easy to 

determine which bottom type export to use.  

Up to ten targeted ground truth points are created to collect field information about the benthic 

substrate and presence of aquatic vegetation to assist in classifying the habitat layers for the final maps.  

Field crews visit the targeted ground truth points within one month of the original survey to minimize 

seasonal changes to the benthic features.  

To create the targeted ground truth points: 

1. Choose the “Marker” symbol from the ArcMap Drawing Toolbar. 

2. Place the marker at the location for the first targeted ground truth point.  

3. Repeat for the remaining points. 
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4. Select all and choose “Convert Graphics to Features” from the Drawing Toolbar and save as 

“DXX_Site_surveyYear_TGT”. 

5. Open the attribute table and add a “pointID” text column, a “easting” double column, and a 

“northing” double column. 

6. Edit the attribute table to label the points 1-10 in the “pointID” column. 

7. Right click on each coordinate column to use “Calculate Geometry” to fill in the location 

information. 

8. In GPS Pathfinder Office “Import” the shapefile to an .imp for field staff to use in the Trimble 

receiver.  

After the targeted ground truth points have been checked in the field add the targeted ground truth 

point field information to the maps created above to determine the final habitat layers. 
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SOP D Creating the Final L4 Outputs 

Use Table 1 to verify all the L4 outputs are created and named correctly. Each file is named “DXX_Site”, 

“BATH” or “HABITAT”, “SurveyDate”, file type.  

1. Check the “DXX_SITE_BATH_surveyDate_tracks.csv” to see if the bottom type exported in 5.1.7 

matches the number of bottom types that was determined to be the best fit. 

a. If necessary re-export the tracks file from Visual Aquatic with the correct number of 

bottom types. 

i. Note: this may require a re-analysis of bottom types in Visual Aquatic. 

2. Save the VA dataset in the final L4 output folder in Visual Aquatic by File>Save Dataset as and 

browsing to the final output folder.   

a. Be sure to remove all shapefile and .csv outputs in the folder so just the BioSonics 

analysis files remain, usually a “cache” folder and .vhx files.  

3. Edit the bottom type shapefile that was selected as the best fit. 

a. Make sure all the habitat polygons are dissolved so there is one row per habitat type. 

b. Open the attribute table and create a text “Habitat” field and a double “Area_m2” field. 

c. Fill in the “Habitat” field with the site specific values. 

d. Calculate the area: 

i. Right click on “Area_m2” attribute field > Calculate Geometry 

1. Property: Area 

2. Coordinate System: Use PCS: WGS 1984 UTM Zone xN 

3. Units: Square Meters [sq m] 

4. OK 

b. Export or rename the files as “DXX_SITE_HABITAT_YYYYMMDD”. 

c. Open the .dbf in excel and save as .csv with the name 

“DXX_SITE_HABITAT_YYYYMMDD_area.csv” 

2. Create the final pdf maps and kml exports. 

a. Note that the kml conversion cannot support some of the more intricate symbology 

patterns used in the pdf maps. Switch the symbology to a solid color before exporting. 
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7 UNCERTAINTY 

Spatial datasets are not a seamless representation of real-world phenomena. Interpretation of the sonar 

images is inherently subjective and it is difficult to quantify uncertainty that may result. Level 0 data is 

also packaged and served to users so that they can potentially analyze the input data used to create 

bathymetry and habitat maps to better understand the uncertainty associated with the maps. 

7.1 Sonar Unit 

A Biosonics MX, single beam, down looking echo sounder and GPS are used to collect backscatter (signal 

strength) data that are used to map NEON aquatic lakes and non-wadeable (river) reaches during 

bathymetric and morphology surveys.   

7.2 Trimble GPS 

A Trimble GeoXH 6000 or 7000 series GPS unit is used to collect GPS locations for the shoreline 

boundary, in-water features, and during ground truthing activities, throughout the bathymetric and 

morphology survey. Differential correction is applied during post-processing to improve GPS accuracy 

and reduce atmospheric errors by comparing the time signature at a fixed base station (typically CORS 

[Continuously Operating Reference Station]) near the rover file collected from the Trimble unit. The 

resulting file defines a horizontal and vertical accuracy using the root mean square error based on a 68% 

confidence level. NEON has aimed to utilize post-processed GPS positions that are within a horizontal 

and vertical precision of 10cm. Due to dense canopy at some sites and/or distance from base stations, 

not all GPS points surveyed fall within the desired range. 
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APPENDIX A EQUIPMENT 

The following software equipment is needed to implement the procedures in this document. Equipment 

lists are organized by task. They do not include standard field and laboratory supplies such as charging 

stations, first aid kits, drying ovens, ultra-low refrigerators, etc. 

Table 3. Equipment list – Post processing the BioSonics Echosounder data. 

Supplier/
Item No. 

Exact 
Brand 

Description Purpose 
Quan-

tity 

BioSonics 
Visual 
Aquatic  

Y BioSonics Software 
Post processing and data visualization 
software for BioSonics Echosounder 
systems 

1 

BioSonics 
Visual 
Acquisition  

Y BioSonics Software 
Real time data acquisition, storage, and 
playback software for BioSonics 
Echosounder systems 

1 

GPS 
Pathinder 
Office 

Y Trimble Software 
Importing and exporting data to GPS 
Receiver and post processing the 
collected data 

1 

ArcMap or 
ArcPro 

Y ESRI Software 
Spatial data analysis and visualization 
software 

1 
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