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1 DESCRIPTION 

1.1 Purpose 

The Standard Operating Procedure (SOP) described in this document is an extension of the AOS Protocol 

and Procedure: DSC – Stream Discharge (RD[04]). This document outlines the procedures for: 

• ADCP settings and configuration 

• Collecting ADCP discharge measurements using WinRiver II software 

• Collecting ADCP discharge measurements using the Trimaran float, Remote Controlled Boat, and 

Piloted Boat ADCP methods.   

• Evaluating ADCP measurements in the field 

1.2 Scope 

This document provides a change-controlled version of an Observatory procedure. Documentation of 

content changes (i.e. changes in particular tasks or safety practices) will occur via this change-controlled 

document, not through field manuals or training materials. 

1.3 Applies To 

The procedure described in this document is used in the following protocols: 

Doc # Title 

NEON.DOC.001085 AOS Protocol and Procedure: DSC - Stream Discharge  

1.4 Acknowledgments 

NEON acknowledges the current definitive work on this topic, “Measuring discharge with acoustic 

Doppler current profilers from a moving boat” by Mueller, D.S., Wagner, C.R., Rehmel, M.S., Oberg, K.A., 

and Rainville, (2013).   
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2 RELATED DOCUMENTS AND ACRONYMS 

2.1 Applicable Documents 

Applicable documents contain higher-level information that is implemented in the current document. 

Examples include designs, plans, or standards.  

AD[01] NEON.DOC.004300 EHS Safety Policy and Program Manual 

AD[02] NEON.DOC.004316 Operations Field Safety and Security Plan 

AD[03] NEON.DOC.000724  Domain Chemical Hygiene Plan and Biosafety Manual 

AD[04] NEON.DOC.050005 Field Operations Job Instruction Training Plan 

AD[05] NEON.DOC.004104 NEON Science Data Quality Plan 

2.2 Reference Documents 

Reference documents contain information that supports or complements the current document. 

Examples include related protocols, datasheets, or general-information references.  

RD[01] NEON.DOC.000008 NEON Acronym List 

RD[02] NEON.DOC.000243 NEON Glossary of Terms 

RD[03] NEON.DOC.002652 NEON Data Products Catalog 

RD[04] NEON.DOC.001085 AOS Protocol and Procedure: DSC – Stream Discharge 

RD[05] NEON.DOC.005390 Datasheets for AOS Protocol and Procedure: DSC – Stream 
Discharge 

2.3 Acronyms 

Acronym Definition 

ADCP Acoustic Doppler Current Profiler 

GPS Global Positioning System  

LEW Left edge of water (looking downstream) 

MBT Moving Bed Test 

REW Right edge of water (looking downstream) 

2.4 Definitions 

Acoustic Doppler Current Profiler (ADCP): a hydroacoustic current meter used to measure water 

velocity over a depth range using the Doppler effect of sound waves scattered back from particles within 

the water column.   

Area (A): The cross-sectional area of a stream or a subsection of a stream. For a rectangular subsection, 

it is the width times the depth. For an irregular cross-section, it is the summation of a series of 

subsection areas, or the width times the average depth. 

Control: A specific section of a stream channel, located downstream from the staff gauge that controls 

the relation between gauge height and discharge at the staff gauge.   
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Depth (D): The depth of the water column at a particular point, measured from the water surface to the 

stream bottom. 

Discharge (Q): The volume of water flowing through a cross-section during a given period of time, 

measured in units of volume per unit time, such as cubic feet per second, cubic meters per second, liters 

per second, gallons per minute, or acre-feet per year. Discharge is computed as velocity times area. 

Fulcrum: Software tool used to create NEON electronic data entry applications. 

Left edge of water (LEW): The edge of the stream that is on the observer’s left when looking 

downstream. 

Right edge of water (REW): The edge of the stream that is on the observer’s right when looking 

downstream. 

ServiceNow: Software tool used for problem/incident tracking and resolution. 

Stage: Height of a stream or river relative to a fixed point. Stage can be measured at a single point in 

time by reading the water level on a calibrated staff gauge mounted in the stream channel, or by using a 

weighted measuring tape to measure down from a fixed point to the water surface. Stage can also be 

measured continuously with a pressure, optic or acoustic sensor, or a staff gauge. 

Thalweg: The line that connects the deepest part of the active channel.   

Transect: The stream cross-section under the measuring tape stretched across the measuring section, 

along which velocity measurements are made to compute discharge. 

Velocity (V): The speed of water flowing past a point along the transect, measured in units of rate, such 

as liters/meters per second.   

Reciprocal Transect Measurements: a pair of ADCP transect measurements, with one measurement 

starting from the right bank and the other starting from the left bank.  
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3 SAFETY 

This document identifies procedure-specific safety hazards and associated safety requirements. It does 

not describe general safety practices or site-specific safety practices. 

Personnel working at a NEON site must be compliant with safe field work practices as outlined in the 

Operations Field Safety and Security Plan (AD[02]) and EHS Safety Policy and Program Manual (AD[01]).  

Additional safety issues associated with this field procedure are outlined below. The Field Operations 

Manager and the Lead Field Technician have primary authority to stop work activities based on unsafe 

field conditions; however, all employees have the responsibility and right to stop their work in unsafe 

conditions. 

While measuring discharge using the ADCP Method, adhere to the following safety considerations: 

• Activities in streams and rivers should only be performed when flow conditions are safe.   

• Never enter the channel when it is unsafe to do so.   

• Be aware of the potential for downstream debris transport as stage increases.   

• Logs, debris, cobble, and boulders can be very slippery and unsafe to walk on. Ensure that all 

staff have proper PPE to reduce risk and maximize safety.   
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4 PERSONNEL 

4.1 Training Requirements 

All technicians must complete protocol-specific training as required in the Field Operations Job 

Instruction Training Plan (AD[04]). Additional protocol-specific required skills and safety training are 

described here. 

Personnel should be:  

• Trained in Water Safety Awareness. 

• Trained in collecting ADCP discharge measurements. 

4.2 Specialized Skills 

The following expertise is required to collect discharge measurements using the Flowmeter method: 

• Experience reading a staff gauge for water level measurement.  

• Experience using the ADCP to measure stream and river discharge. 

• Experience using WinRiver II and Q-Rev software for data collection and review.   

• Experience using the mobile application for data entry.   
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5 CONTINGENCIES AND NOTES 

A dedicated laptop is required to measure discharge using the ADCP Method. The ADCP laptop must 

have the following programs installed: 

• WinRiver II  

• Q-Rev 

• ParaniWin 

• ParaniUpdater 

Contact the Domain IT Liaison or submit a ServiceNow ticket to the NEON IT department for questions 

about installing or accessing these programs on the ADCP laptop.   
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6 STANDARD OPERATING PROCEDURES 

 

Figure 1. A high level workflow diagram that visually shows how the separate SOP sections are sequentially 
connected. 
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SOP A Establishing and Testing Bluetooth Connections for the ADCP and GPS antennas 

The StreamPro and RiverPro ADCPs and SX Blue and Hemisphere GPS antennas communicate with 

WinRiver II software wirelessly via a Bluetooth connection. Two Parani SD1000U Bluetooth transmitters, 

or dongles, are required to send data from the sensors to the ADCP laptop – one for the ADCP and one 

for the GPS antenna. It is a good idea to have an extra dongle on hand in the field as a spare. The Parani 

Bluetooth dongle contains a USB interface adapter that is plugged into a laptop COM port. Parani 

Bluetooth dongles are setup and configured using ParaniWin software.  

 When the same laptop is used for ADCP measurements (this is required for ease of communication 

setup and software availability) the following setup should only need to occur prior to the initial 

measurement. Following the initial setup, the ADCP and GPS antenna should automatically connect to 

the laptop software via the dongles. Information in the following sections should also be used when 

troubleshooting connection problems.   

To avoid confusion, it is helpful to label one dongle “ADCP” and the other “GPS” and place a sticky note 

near the laptop port each are plugged into that designates an “ADCP” or “GPS” connection.    

Setup, testing, and troubleshooting should be conducted in the office prior to deployment to save time 

in the field and in the case that an internet connection is needed. An ADCP discharge measurement 

cannot be completed if Bluetooth communications are not properly configured.   

A.1 Parani Dongle Configuration 

Start by physically configuring the ADCP and GPS Parani dongles. Each Parani dongle has a set of four 

DIP switches that are used to set the Bluetooth adapter’s baud rate and data flow control. These DIP 

switches need to be in the correct physical configuration using a small screwdriver, pocketknife, pen, or 

similar tool.  

Move the DIP switches to the correct position in order to set the Baud Rate to 11520Kb on both Parani 

dongles. The diagram on the left of each dongle (Figure 2) shows how the positions of each switch relate 

to baud rate configuration. To physically configure the Parani Dongles: 

1. Set the first and second DIP switches to the right. 

2. Set the third DIP switch to the left (115200 baud rate). 

3. Set the fourth (bottom) DIP switch to the left (HW Flow Control OFF). 
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Figure 2. Top: Parani-SD1000U USB Bluetooth Adapter with default settings; Bottom: Correct settings for ADCP and 
GPS Bluetooth configuration. 

Once physically configured, each dongle needs to be initially setup with the ParaniWin software. 

Complete the following steps for the ADCP dongle, then repeat for the GPS dongle. Note that this 

information is also contained in the document entitled “Guidance for StreamPro Bluetooth setups” that 

is included with all ADCP materials. 

4. Ensure that the ADCP and GPS units are powered and fully connected to the trimaran float.     

5. Plug the Parani dongle into a USB port on the laptop.   

6. Use Windows Device Manager to determine the laptop COM (communication) port that the 

Parani is assigned to.  

a. Unplug and re-connect the Parani dongle to note which COM port number appears and 

re-appears in the Device Manager. This is the COM port the Parani dongle is assigned to. 

i. If using Windows XP and later systems, the driver will likely load automatically 

when you plug in the Parani dongle.   

ii. If the Parani is not showing up in the Ports (COM & LPT) node, it may show up in 

the “Other Devices” node.   

1) If this is the case an update to Parani firmware is required. 
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2) Once complete, open Windows Device Manager, right click on the 

appropriate COM Port that the Parani is assigned to and navigate to the 

Drivers window.  

3) Choose “Browse my computer software for driver software”.  

4) Click “Next” and it will respond with a message of success or failure.  

5) If successful, close this window and return to Windows Device Manager. 

The Parani should now appear under the COM Ports node.  

6) In unsuccessful, contact the Domain IT Liaison or submit an incident ticket 

to NEON IT for troubleshooting.  

7. Right click on the COM port assigned to the Parani dongle and select “Properties” > “Port 

Settings”. 

8. Configure Port Settings. 

a. Bits per second = 115200. 

b. Data bits = 8 

c. Parity = None 

d. Stop bits = 1 

e. Flow control = None 

9. Click on the “Advance Settings” button. 

a. Check the COM port number assigned to the Parani in the top of the Advanced Settings 

window.  

b. In the “BM Options” section, select the “Latency Timer” drop down and set to 1msec.  

c. Click “OK” twice to exit Windows Device Manager. 

10. Note the LED indicators on the Parani dongle.  

a. The “Mode” LED indicates which mode the Parani dongle is currently configured to.   

b. Ensure the Parani dongle is set to MODE1, the LED will blink green at 1 second intervals. 

c. The “Connect” LED indicates whether the Parani dongle is connected to the ADCP/GPS 

unit, the LED will blink green at 1 second intervals. 

11. Open the ParaniWin software to configure the Bluetooth connection. 

a. The UART Setting window will automatically pop up that displays the communication 

settings between the Parani dongle and the laptop.  
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b. Ensure that the configured settings are set correctly. These settings must match both 

the COM port and physical dongle settings or the dongle will not be able to 

communicate with the laptop.      

i. Serial port: Select the laptop COM port number the Parani dongle is assigned to 

(as shown in Windows Device Manager). 

ii. Baud rate: 115200 

iii. Parity: None 

iv. StopBit: 1 

v. Click “OK”. The initial configuration is now complete. 

c. Select the “Device Setting” tab. 

i. Set “Operation Mode” to “MODE1”. 

ii. Check that Device Settings are the same as what was entered in the UART Setting 

Window.   

iii. Under “Security Option” check the “Authentication” box and enter one of the 

following codes for the “Pin Code”. 

1) When configuring the ADCP dongle, enter “0000”. 

2) When configuring the GPS dongle, enter “12345678”. 

iv. Click “Apply”.   

v. A “Completed Configuration” message will appear.  

1) If the connection was unsuccessful: review the physical Parani dongle 

settings, the COM port settings in Windows Device manager, and the 

settings entered in ParaniWin and repeat the steps above.  

d. Select the “Connection (out)” tab. 

i. Click the “Search” button. This will ping all available wireless networks that are 

within range of the laptop.   

ii. Chose the desired instrument to connect to and click “Connect” (ADCP and GPS 

labels may vary). 

1) The ADCP should be shown as “RDI SPro” or “RDI RPro” depending on the 

ADCP model. 

2) The GPS should be shown as “SX Blue GPS” or “Hemisphere GPS” 

depending on the GPS model.  

3) Click “Connect”.   
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iii. A window will pop up with a “Connected successfully message”.  

iv. One of the lights on the ADCP will turn blue, indicating that the Bluetooth 

connection was successful.   

1) If the connection was unsuccessful: review the physical Parani dongle 

settings, the COM port settings in Windows Device manager, and the 

settings entered in the ParaniWin software and repeat the steps above. If 

needed, contact the Domain IT Liaison or submit an incident ticket to 

NEON IT for troubleshooting. 

12. Close the ParaniWin software once both the ADCP and GPS dongle are connected to the laptop. 

If the ParanWin program is not closed, WinRiver II software will not be able to connect to either 

device.  

A.2 Testing the GPS and ADCP connections in WinRiver II 

Once both ADCP and GPS dongle connections have been successfully connected via Bluetooth, the 

connections must be tested in WinRiver II software in order to ensure that data can be transmitted to 

the program. This must be done prior to each discharge survey that utilizes ADCP instrumentation and is 

best completed in the office in case additional troubleshooting is needed.   

1. Ensure that the ADCP is fully powered (green light will be on) and setup for Bluetooth 

communications via the Parani dongle (blue light will be on).  Ensure that the ADCP Parani 

dongle is installed in the designated COM port.  

2. Open WinRiver II software.   

3. In the WinRiver II main screen, select “Configure” > “Peripherals”. 

a. Test ADCP communications. 

i. In the “Peripheral Configuration Dialog” window, under the “Peripherals” node, 

double click on the “Read Serial Raw ADCP Data” button. 

ii. Double click on “Port: ADCP Serial Port”. 

iii. Check that COM settings are correct and press “OK”. 

iv. With “Port: ADCP Serial Port” still highlighted, click the “Test Port” button on the 

right.   

v. A dialogue box will open, and information should begin streaming regarding 

Teledyne StreamPro firmware (Figure 3). This indicates that the ADCP is 

recognized by the WinRiver II software.  

1) If nothing appears in the dialogue box, WinRiver II is not recognizing the 

ADCP.   
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2) Ensure that ParaniWin software is closed. If open, close this program and 

repeat the Peripheral test.   

3) If ParaniWin software is closed and the Bluetooth connection was 

successful in that program, check COM settings in “Port: ADCP Serial Port” 

and repeat the Peripheral test. 

4) If nothing appears in the dialogue box, continue on to the next step for 

GPS testing.  Further ADCP testing can be completed in the Configuration 

Dialogue tab of the Measurement Wizard window.    

vi. Click “Stop” and “Close” to cease testing and close the test dialogue window.   

 

Figure 3. ADCP Test Port Dialog indicating that ADCP data are streaming from the ADCP to the laptop. 

b. Test GPS communications (if using the Sirius XS Blue GPS antenna). 

i. The GPS cannot be tested in this environment if using the RiverPro ADCP and 

Hemisphere GPS antenna setup as GPS data are wired through the RiverPro ADCP 

cables. If, using the steps below, ADCP data are recognized in the Test Port Dialog 

window, it typically indicates that GPS data are also properly configured.  

ii. Ensure that the GPS antenna is fully powered (green light is on) and the GPS 

Parani dongle is installed in the designated COM Port.     

iii. In the “Peripheral Configuration Dialog” window, under the “Peripherals” node, 

double click on “Read NMEA GPS Data 1”. 
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iv. Double click on “Port: GPS Serial Port”. 

v. Check that COM settings are correct and press “OK”. 

vi. With “Port: GPS Serial Port” still highlighted, click the “Test Port” button on the 

right. 

vii. A dialogue box will open, and GPS data should begin streaming (Figure 4). This 

indicates that the GPS is being recognized by the WinRiver II software.   

1) If nothing appears in the dialogue box, WinRiver II is not recognizing the 

GPS.   

2) Ensure that ParaniWin software is closed. If open, close this program and 

repeat the Peripheral test.   

3) If ParaniWin software is closed and the Bluetooth connection was 

successful in that program, check COM settings in “Port: GPS Serial Port” 

and repeat the Peripheral test. 

4) If nothing appears in the dialogue box, further GPS testing can be 

completed in the Configuration Dialogue tab of the Measurement Wizard 

window.    

viii. Click “Stop” and “Close” to cease testing and close the test dialogue window.   

 

Figure 4. GPS Test Port Dialog indicating the Sirius XS Blue GPS data are streaming from the GPS antenna to the 
laptop. 
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SOP B Collecting an ADCP Discharge Measurement Using WinRiver II 

Once the trimaran float, ARC-Boat, or piloted boat ADCP deployment assemblies have been properly 

configured (see RD[04] for details on the physical setup for each of these ADCP methods), a new 

measurement file can be created using WinRiver II software. Reference the following sections for 

instructions on: 

• Starting a new measurement file in WinRiver II 

• Conducting pre-measurement QAQC procedures, including: 

o Setting the ADCP clock 

o Configuring ADCP reference navigation  

o Calibrating the ADCP internal compass 

o Executing the ADCP diagnostic test 

o Collecting an independent water temperature measurement 

o Performing Loop and Stationary Moving Bed tests 

• Establishing Transect Start and End Points 

• Collecting Transect Discharge Measurements 

• Evaluating ADCP Discharge Data in WinRiver II 

B.1 Starting a New Measurement File in WinRiver II 

To start a new measurement in WinRiver II software: 

1. Ensure that the laptop is set to the UTC timezone and start the WinRiver II program. 

2. In the WinRiver II main screen, select “Configure” > “Units” > “All SI” to set units to metric.   

3. In the WinRiver II main screen, select “File” > “New Measurement” to initiate the Measurement 

Wizard. 

4. In the “Setup Dialog” window, fill out required fields in the “Site Information” (Table 1) and 

“Rating Information” (Table 2) tabs. 

a. Fields not listed in the tables are not required and can be left blank, or at default values.  

b. Information in these two tabs can be entered anytime (e.g. Water Temp, Measurement 

Quality, Remarks), but is best practice to enter as much as possible in the beginning of 

the measurement. 

c. Reference Table 3 for Wind Direction data entry requirements. If this field is not entered 

correctly, the measurement file will fail validation in the post-processing application.  
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Table 1. Descriptions and data entry examples of required fields in the Site Information tab of the Setup Dialog 
window of WinRiver II. 

Field Description Example Entry 

Station Name Four digit site code  TOMB 

Agency The name of our monitoring program NEON 

Field Party Field staff initials, separate with comma NH, KG 

Processed By Initials of staff that post-processed the measurement NH 

Deployment 
Type 

Type of ADCP deployment used during measurement 
Tethered boat, Remote 
Control 

Meas. Location 
A code that identifies the location of the discharge 
cross-section 

DSC, DSC_US 

Remarks 
A space to leave any notes that describe the 
measurement 

Moving bed unlikely due to 
low flow 

 
Table 2. Descriptions and data entry examples of the required fields in the Rating Information tab of the Setup 
Dialog window of WinRiver II. 

Field Description Example Entry 

Inside Gauge 
Height 

The water level measured on the staff gauge (gauge data must 
also be entered in the Discharge app) 

0.495 

Water Temp Independent water temperature measurement, see SOP B.6 6.7 

Magn Variation 
Method 

The method in which magnetic variation is quantified Model 

Measurement 
Rating 

Assessment of measurement quality made by staff collecting / 
processing the measurement 

Good (5%) 

Wind Speed 
Wind speed measured in kilometers per hour using an 
anemometer (if no wind enter “0.0”) 

0.3 

Wind Direction 
The direction the wind is blowing, using set terms listed in 
Table 3 

See Table 3 

Edge Method 
The method that was used to determine edge of water 
distances during transect measurements 

Meter tape, laser 
rangefinder 

Table 3. Required Wind Direction entries in the Rating Information tab of the Setup Dialog window in WinRiver II. If 
the exact terms are not used, the measurement will fail validation during post-processing and the Wind Direction 
value will require an edit by the user.  

Condition  Required Wind Direction Entry 

The wind is blowing upstream “Upstream” 

The wind is blowing downstream “Downstream” 

The wind is blowing across the channel “Cross-wind” 

The wind is blowing, but not in any particular direction “Mixed” 

There is no measurable wind “NA” 
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5. Select the “Configuration Dialogue” tab. 

a. The software will try to recognize the ADCP (this can take a few minutes).  

i. If successful, the button next to “ADCP” will turn green, indicating that WinRiver II 

recognizes the ADCP via the Parani dongle.  

ii. If unsuccessful, a window will appear that says ““The ADCP is not responding…” 

indicating that WinRiver II does not recognize the ADCP.   

1) Ensure Parani configuration was successful and that ParaniWin software is 

closed. Repeat steps in SOP A as needed.  

2) In the “ADCP” dropdown, ensure that the correct ADCP model is selected. 

Select the “Check ADCP” button to re-test configuration. 

3) The ADCP must be recognized by the software for the discharge 

measurement to be conducted. If communication problems persist, 

submit a trouble ticket for further troubleshooting.    

b. If external GPS is available (see SOP B.3) check the GPS configuration settings. 

i. Ensure that the GPS antenna is attached, powered, and properly configured 

(RD[04]).  

ii. Check the “Int. GPS” box. 

1) Set the baud rate to 19200. 

iii. Check the “Ext. Heading box”. 

1) Leave the “Hdg Off [deg]” box blank (error message can be ignored). 

2) An external heading offset may be required for ADCP deployments with 

the ARC-Boat and the Hemisphere V102 GPS unit (Appendix C). 

iv. The “Depth Sounder” box can be left blank. 

c. Under “Offsets”: 

i. Enter the “Transducer Depth”, the depth of the ADCP transducer below the water 

line. Record this measurement to the nearest centimeter.   

1) For trimaran float and ARC-boat deployments, place the float or boat in 

the water, mark the waterline with a Sharpie, and using a ruler or meter 

tape, measure the distance from the mark to the center of the slant in the 

ADCP transducer faces. Enter this value in the field.  

2) This is a very important measurement as it establishes the unmeasured 

area at the top of the water column, can significantly affect the number of 

Good Bins available during transect measurements, and controls the total 
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measured discharge associated with the measurement. Verify this 

measurement multiple times as needed.   

3) This value can be adjusted during the measurement by selecting “Field 

Configuration” > “Offsets” under individual Transect nodes in the 

Measurement Ctrl window, or during post-processing by selecting 

“Playback Configuration” > “Offsets” under individual Transect nodes in 

the Measurement Ctrl window.  

ii. Enter the “Magnetic Variation”, the angle declination relative to the site latitude 

and longitude.  

1) Reference the NOAA Magnetic Field Calculators webpage for this value.  

6. Select the “Output Filename Options” tab. 

a. Under the “Recording” section: 

i. Enter the four-digit site code in the “Filename Prefix” box. 

ii. Ensure that the “Use Prefix in Filename” box is checked. 

iii. Adjust the “Output directory” as needed to setup where the file will be saved. 

b. Adjust all other filename options as needed; the directory listed under in the “Filename 

Preview” indicates what the file path will look like based on the settings selected.  

7. Review the “Summary Page” tab to ensure that all settings are configured as expected. 

8. Click “Finish” to complete the Measurement Wizard.  

B.2 Pre-Measurement QAQC: Setting the ADCP Clock 

Laptops used for ADCP measurements must be set to UTC time. Prior to the discharge survey, the ADCP 

clock must be set to match the PC time (UTC). Failure to properly set the ADCP clock will result in data 

files with incorrect timestamps.   

To set the ADCP clock: 

1. Set the time zone on the PC to (UTC) Coordinated Universal Time. 

a. Right click on the Date/Time reading in the lower right corner of the PC screen. 

b. Select “Adjust date/time”. 

c. In the “Time zone” dropdown, select “(UTC) Coordinated Universal Time” (Figure 5). 

2. In the WinRiver II main screen, select “Acquire” > “Set ADCP Clock”. 

3. Set the ADCP clock to match the PC time (UTC).   

4. Click the “Set Clock” button. 



 

Title: AOS Standard Operating Procedure: DSC – Configurations, Settings, and Collection 
Methods for Stream Discharge Measurements using the ADCP Method 

Date: 05/14/2024 

NEON Doc. #: NEON.DOC.005389 Author: N. Harrison Revision: A 

 

SOP B 

 

Page 19 

a. Note: just clicking the “OK” button will not set the clock, the “Set Clock” button must be 

selected. 

 
Figure 5. Set the PC used for the ADCP measurement to (UTC) Coordinated Universal Time and match the ADCP 
clock to this setting. 

B.3 Pre-Measurement QAQC: Configuring the ADCP Reference Navigation 

The ADCP reference navigation determines how the direction or bearing (heading) of the instrument is 

measured. Reference navigation can be toggled prior to, during, and following the discharge 

measurement.  

The following reference navigation types are available during an ADCP discharge measurement: 

• Bottom Track (default setting and primary choice) 

o ADCP Bottom-Track velocity (standard configuration). 

o This is the primary choice for the reference navigation if a moving bed is not suspected 

and/or GPS data are not available.   

o The ability of the ADCP to Bottom Track can become compromised due to insufficient 

depth, low batteries, and/or periods of high turbidity.  

▪ If depth is < 0.25m, the ADCP may not be able to Bottom Track due to 

unavailability of good bins. The Flowmeter method should be considered for 

discharge during low stage levels. 

▪ If ADCP battery voltages are < 10V, the ADCP may be unable to Bottom Track. 

Ensure fresh batteries are available during every ADCP discharge measurement.  

▪ An overload of scatterers are produced during periods of high turbidity which 

prevent ADCP beams from reaching the bottom of the channel and comprise the 

ability of the instrument to compute velocity throughout the profile. Under these 
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conditions, large bands of missing ensembles are present in the velocity contour 

profile. GPS should be used as the reference navigation under these conditions, if 

available.  

• GPS (GGA) 

o Differential GPS position from NMEA GGA string (WinRiver II will differentiate position to 

calculate velocity). 

o If a moving bed is detected and/or during periods of high turbidity, this is the primary 

choice for GPS reference as GGA data contains more information than VTG. 

o GGA messages can be affected by multipath errors caused by canopy above the stream 

and/or structures nearby the measurement site. 

• GPS (VTG) 

o GPS velocity from NMEA 0183 VTG string.   

o If a moving bed is detected, and/or during periods of high turbidity, this is the secondary 

choice for GPS reference as VTG data serves as a backup for GGA.   

o VTG messages are not affected by multipath errors, but VTG GPS data is oftentimes less 

accurate than GGA, particularly when moving at lower speeds.  

To change the Reference Navigation type used by the ADCP during the measurement: 

1. In the WinRiver II main screen, select “Configure” > “Reference”. 

2. Select the appropriate navigation type.  

B.4 Pre-Measurement QAQC: Calibrating the ADCP Internal Compass 

The ADCP internal compass must be calibrated prior to each discharge survey. Compass calibration is 

particularly essential when conducting Moving Bed Tests and when GPS is used as the reference 

navigation. Calibrating the compass is a two person task; one staff member must monitor the calibration 

data in real time while another rotates the ADCP within the trimaran float, ARC-Boat, or other mount 

type. Follow the steps below to calibrate the ADCP internal compass. 

To calibrate the ADCP internal compass: 

1. Ensure that the ADCP is secured within the mount at the exact position it will remain in 

throughout the discharge measurement.   

2. Ensure that the ADCP is not located near vehicles, steel bridges, or other large ferro-magnetic 

masses. Check for any materials near the ADCP that could disrupt the compass calibration – 

including tools, toolboxes, cell phones, hot hands, etc.  

3. In the WinRiver II main screen, select “Acquire” > “Execute Compass Calibration”.   
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4. Select “Use Pitch/Roll”. 

a. Select “No” if the ADCP will not be subject to pitch and roll (i.e. calm water conditions 

are present). This calibration test requires two rotations, one for calibration and one for 

verification. Typically, no pitch and roll calibration is required.   

b. Select “Yes” if the ADCP will be subject to very high pitch and roll conditions. This 

calibration test requires up to eight rotations, four for calibration and four for 

verification.  

5. The ADCP compass calibration can be conducted on land or in the water.  

a. If conducted on land (recommended for trimaran float deployments), the ADCP (within 

the float) can be placed on a non-metallic Lazy Susan (or similar device) to ensure a 

smooth 360 degree rotation.   

b. If conducted on water (recommended for ARC-Boat or piloted boat deployments), the 

ARC-Boat or piloted boat can be turned in the water, ideally in an eddy or section of the 

river near the bank where minimal velocity is present.  

6. Select the “Start Calibration button” and wait a moment until the compass is initialized by the 

software. 

7. Once initialized, begin to rotate the ADCP slowly and smoothly by hand in the clockwise 

direction, taking care to avoid acceleration or deceleration in the rotation.  

8. Rotate the ADCP until all of the red bars in the dialogue window (Figure 6) have been replaced 

by dark green (preferred) or light green (accepted) bars. 

a. Dark green bars indicate less compass error. If a bar is not dark green, rotate the boat 

more slowly and more smoothly.   

b. Correct any non-dark green bars by rotating back 10-20° until the bar is once again 

highlighted. Then, when it becomes dark green, rotate back in the original direction.   

c. Clear and constant communication between the staff member moving the boat and the 

staff member viewing the test on the laptop is critical during this period.    

9. Once the first rotation is complete, the software will require another rotation in the opposite 

direction.  

10. A calibration error will be displayed once all rotations are complete.  

a. A calibration error of < 2° is acceptable and the compass calibration is complete. A 

calibration error of < 1° is preferred.  

b. If calibration error is ≥ 2°, do not accept the compass calibration and repeat calibration 

procedures. Reference troubleshooting solutions provided in Table 4.    
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c. If, after three attempts, a calibration error of < 2° cannot be achieved, accept the 

calibration results, make a note in the Remarks section of the “Site Information” tab, 

continue with the discharge measurement, and submit an incident ticket for further 

troubleshooting. 

 
Figure 6. WinRiver II compass calibration dialog box. Upon initializing the compass calibration, all bars begin as 
bright red as shown above. Perform the compass calibration until all bars are the dark green color indicated in the 
far right side of the color scale. 

Table 4. Troubleshooting issues associated with the ADCP internal compass calibration. 

Calibration Issue Solution 

High calibration 
error  
(>2 degrees) 

Too much magnetic interference may be present in the area. Ensure that no 
magnetic materials are nearby and try moving the ADCP to a different area to 
repeat the calibration. Ensure that the ADCP is being rotated in a slow and 
smooth manner. Correct any non-green bars by counter-rotations during the 
calibration test.  

Computational 
error 

If an error message indicates that a computational error occurred, repeat the 
calibration, and rotate the ADCP in a slow and smooth manner. Ensure that all 
bars in the calibration display are either light or dark green. Correct any non-
green bars by counter-rotations during the calibration test. 

Communication 
error 

If an error message indicates “Failed to get calibration data”, verify that batteries 
are fully charged and ADCP communications are set to the required 115200 baud 
rate. 

Calibration 
Failure 

If an error message indicates that the compass calibration has failed, perform 
calibration again checking the solutions listed above. Disable GPS output (if 
enabled) by unchecking the “Ext. GPS” box in the Measurement Window 
Configuration Dialog tab.  

B.5 Pre-Measurement QAQC: Executing the ADCP Diagnostic Test 

This test must be conducted prior to the discharge survey in order to verify that the ADCP is functioning 

properly and communicating with WinRiver II software. 
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To execute the ADCP Diagnostic test:   

1. Ensure that the ADCP is installed in the proper mount (Trimaran float, ARC-Boat, or Piloted Boat 

assembly) and is submerged in the water. 

2. In the WinRiver II main screen, select “Acquire” > “Execute ADCP Test”.   

3. A dialog window will open and a series of six tests will be initiated that evaluate ROM, RAM, 

Communications, RTC, Compass, and Temperature performance.   

a. Check that all tests pass on the left pane of the dialog window.    

b. If any of the tests do not pass, and the ADCP is still able to function, make a note in the 

Remarks section of the “Site Information” tab, continue with the discharge 

measurement, and submit an incident ticket for further troubleshooting.  

4. After the tests have been run, sensor data will begin to be sampled and displayed in a loop. 

5. Click the “Stop PC20” and “Stop PC40” buttons to end testing and close the dialog window.    

B.6 Pre-Measurement QAQC: Collecting an Independent Water Temperature Measurement 

Temperature is the most important term in the equation used to compute the speed of sound, which 

the ADCP computes to accurately measure velocities, depths, and compute discharge (Mueller et al., 

2013). A water temperature measurement (independent of the built-in ADCP sensor) must be collected 

prior to the discharge survey as a means to check the accuracy of the ADCP temperature data.  

To collect an independent water temperature measurement: 

1. Submerge a thermometer in the water column for at least 5 minutes. 

2. Record the temperature value in the Rating Information tab within the WinRiver II software 

using either the Measurement Wizard (when first setting up the measurement file see SOP B.1) 

or by opening the “Site Information” node within the “MeasurementCtrl” window > selecting 

the “Rating Information” pane in the “Setup Dialog” box (if the Measurement Wizard has 

already been run) > entering the value in the “Water Temp (C)” box.   

3. The independent water temperature measurement should be within 2 degrees of the ADCP 

temperature data after the ADCP has equilibrated to the water temperature.  

a. ADCP equilibration time can vary based on the temperature of the ADCP prior to 

entering the water.  

b. It is recommended that the ADCP is given at least 5 minutes to equilibrate in the stream 

before the first transect measurement. Extend this period as needed if the ADCP has 

been exposed to hot temperatures prior to the measurement.  

4. Select “Acquire” > “Start ADCP” pinging” to enable the ADCP sensor to begin collecting data (the 

sensor is not recording data at this time). 
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5. Select “View” > “Graphs” > “Time Series” > “Temperature” to view the temperature timeseries.  

6. If the difference between the independent temperature measurement and the ADCP 

temperature measurement is >2 degrees, allow the thermometer and ADCP to equilibrate 

longer and re-check the values.  

a. If the temperature differences are >2 degrees, make a note in the Remarks section of 

the “Site Information” tab, continue with the discharge measurement, and submit an 

incident ticket for further troubleshooting.   

B.7 Pre-Measurement QAQC: Performing Loop and Stationary Moving Bed Tests 

Moving Bed Tests (MBT) are used to determine if the bed of the discharge cross-section is in motion. An 

un-accounted for moving bed can lead to 5-10% bias in discharge measurements performed with the 

StreamPro and RiverPro ADCP’s. 

MBTs must be performed prior to each ADCP discharge bout. WinRiver II software analyzes the data 

collected during the MBT to assess the moving bed characteristics of the site and to detect common 

error conditions, which may invalidate the test. Two MBT methods are presented below as a means to 

test whether a moving bed is present. Both the Loop and Stationary MBT methods must be applied 

properly or they may produce incorrect results.   

Performing a Moving Bed Test using the Loop Method: 

The Loop method is the preferred MBT method and should be attempted prior to each ADCP discharge 

method. Consider the following points before attempting the Loop MBT method: 

• A properly calibrated compass is critical to the application of the Loop MBT method. 

• The Loop MBT must last >180 seconds.  

• The Loop MBT is not accurate when mean channel velocity is < 0.24 m/s. 

o If mean velocity is ≤ 0.24 m/s, an error will be displayed in the test result window 

following the Loop MBT.  

o Do not repeat the Loop MBT under these conditions as it is unlikely that a moving bed will 

bias discharge calculations.  

• If mean velocity is > 0.24 m/s, but bottom tracking cannot be maintained, a Stationary MBT 

should be attempted.  

To perform a Loop MBT: 

1. In the WinRiver II main screen, select “Acquire” > “Start Pinging”. 

2. Navigate the ADCP to a starting location close to the edge of water on the near bank.  
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a. If safety allows during trimaran float deployments, use a ziptie, clip, or some device to 

mark the location on the tagline where the Loop MBT will start and end.  

b. For ARC-Boat or Piloted Boat deployments, use any visual cues to remember this 

position.  

3. Select “Acquire”> “Select Moving Bed Test” > “Loop Test” and click the “Start” button to begin 

the Loop MBT (shortcut key: F4).  

4. Begin navigating the ADCP across the channel in a slow and steady manner towards the 

opposite bank. 

a. Note that the green square in the Ship Track graph denotes the starting location (select 

“View” > “Graphs” > “Ship Track” to access this graph. Once the test is complete, the red 

square will appear that indicates where the Loop MBT ended (Figure 7).  

b. Maintain a steady speed that does not exceed the stream velocity. 

i. Select “View” > “Graphs” > “Timeseries” > “Water / Boat Speed” to view these 

data.  

 

Figure 7. The WinRiver II Ship Track window displaying a Loop moving bed test. The green box indicates the ADCP 
starting position; the line shows the ADCP path as it navigates across the channel and turns back around toward 
the starting bank; the red box indicates the ADCP ending position. In this example, a moving bed is not present as 
the loop is closed and the red box is on top of the green box.   

5. The Loop MBT must last >180 seconds (from the near bank to the opposite bank and back).  

a. It is helpful for one staff member to monitor data on the laptop while another staff 

member operates the ADCP. The data monitor should update the operator on elapsed 

time and whether speed adjustments are needed.  

6. Once the opposite bank is reached, make a smooth and slow turn (don’t stop) so that the ADCP 

is heading back to the near bank where the test began.  
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7. Once the ADCP has returned to the exact starting point on the near shore (where the test 

began), immediately select “Acquire” > “Stop Moving Bed Test” (shortcut key: F6) to stop the 

Loop MBT.   

a. Not returning the ADCP to the exact starting point can result invalidate test results or 

lead to a false positive (a moving bed is incorrectly detected).   

8. Evaluate the Loop MBT results.  

a. Open the Moving Bed Test Result window to evaluate test results and any errors 

associated with the MBT. 

i. In the top left Measurement Ctrl window, open the “QA/QC” node > open the 

“Moving Bed Test” node > open the test that was just completed (Loop tests begin 

as “Loop 000”) > double click on the “Test Result” icon.  

ii. If no errors are present, the “NOTE” at the bottom of the window will indicate 

whether a moving bed is present and if a correction is recommended (Figure 8).  

iii. Errors in the Loop MBT are typically due to inadequate velocity, duration, or 

bottom tracking (Table 5).  

b. The Loop MBT can also be evaluated using the Stick Ship Track graph (Figure 9).  

i. Select “View” > “Graphs” > “Stick Ship Track”. 

ii. If the track (red line) contains an “open mouth” (i.e. the red line is not connected 

in a loop) this may indicate that a moving bed is present. 

iii. If the track does not contain an “open mouth” (i.e. the red line is connected in a 

loop), this indicates that a moving bed is likely not present.  

iv. Moving bed conditions will always cause the ship track to move upstream – if the 

ship track moves downstream, the loop test is not valid.  
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Figure 8. Moving Bed Loop Test Result window. In this example the required conditions were met to in order to 
evaluate whether a moving bed was present (Loop time, water velocity, and bottom tracking). A moving bed was 
not detected (the moving bed velocity < the moving bed velocity criteria) and no correction is recommended.  

 

 

Figure 9. Left: A moving bed is likely present (not open loop); Right: a moving bed is not likely present (note closed 
loop). 

9. If a moving bed is detected and a correction is recommended:  

a. Check the box to the left of the MBT (i.e. “Loop 000”). This will apply a correction to the 

measured discharge to account for the moving bed velocity. Note that a discharge 

correction has been applied to the measurement in the Remarks section of the “Site 

Information” window.  
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b. The discharge correction can also be toggled on and off during post-processing.   

c. If GPS data are available and valid, change the Navigation Reference from Bottom Track 

to GPS (GGA) (see SOP B.3).  

10. If a moving bed is not detected and no correction is recommended: 

a. Continue with the discharge measurement with Bottom Track set as the reference 

navigation.  

11. If the test results in an error:  

a. Repeat the test a second time.  

b. If, after the second test, the results are still not accurate, change the Navigation 

Reference from Bottom Track to GPS/GGA (if available, see SOP B.3). 

12. Document any relevant notes that apply to the Loop MBT. 

a. In the top left Measurement Ctrl window, open the “QA/QC” node > open the “Moving 

Bed Test” node > right click on the test that was just completed (Loop tests begin as 

“Loop 000”) > select “Add Note”.  

Table 5. Troubleshooting issues associated with the ADCP Loop Moving Bed Test. 

Loop Moving Bed 
Test Error 

Repeat Moving 
Bed Test? 

Solution 

Mean Velocity 
< 0.24 m/s 

No 
Velocity is too low to produce a moving bed, continue on 
with discharge measurement 

Test duration  
< 180 seconds 

Yes 
Repeat the Loop MBT ensuring the test duration is >180 
seconds. 

Percentage of bad 
bottom track values 
exceeds 20.0 

High flow = Yes 
Low flow = No  

Check ADCP battery voltages, low batteries can lead to 
poor bottom tracking. Consider conducting a Stationary 
MBT if velocity is high. If velocity is low, do not complete 
another MBT and continue with the discharge 
measurement. 

Consecutive invalid 
Bottom Track 
exceeds 9.0 seconds 

High flow = Yes 
Low flow = No  

See above solution. Review the Velocity Contour graph 
associated with the MBT, you may need to start and/or 
end the MBT farther away from the edge of water where 2 
Good Bins are available.   

 

Performing a Moving Bed Test using the Stationary Method: 

A Stationary MBT can be performed if moving bed conditions are suspected and errors were 

encountered during a Loop MBT. Stationary tests are considered the secondary option for MBTs as: 

• Stationary MBTs typically take longer to perform than Loop MBTs. 

• It can be difficult to maintain a steady ADCP location for prolonged periods (particularly with 
non-trimaran float deployments during high flows). 
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• Stationary MBTs only evaluate conditions at specific locations within the channel, rather than 
throughout the full cross-section.  

To perform a Stationary MBT: 

1. In the WinRiver II main screen, select “Acquire” > “Start Pinging”. 

2. Navigate the ADCP to a location where the bed is most likely to be mobilized (e.g. the thalweg).   

3. Select “Acquire”> “Select Moving Bed Test” > “Stationary Test” and click the “Start” button to 

begin the Stationary MBT (shortcut key: F4).  

4. Steady the ADCP in this location for at least 10 minutes, attempt to minimize any movements.  

5. After 10 minutes have elapsed, select “Acquire” > “Stop Moving Bed Test” (shortcut key: F6) to 

stop the Stationary MBT.   

6. Follow the steps listed above in the Loop MBT section to evaluate and apply the results of the 

Stationary MBT. 

B.8 Establishing Transect Start and End Points 

The locations on each side of the channel where transect measurements start and end must be 

established before recording discharge data. Depth becomes too shallow for valid ADCP data collection 

near each bank; thus discharge must be estimated in these zones using the WinRiver II and Q-Rev 

software. To ensure the accuracy of near-shore discharge estimates, the distances from the edge of 

water to the starting and stopping points of each transect must be physically measured in the field using 

a measurement device such as a meter tape or laser rangefinder.  

Some notes on transect start and end points: 

• Establishing transect start and end points is done while depth, distance, and velocity data are 

being measured by the ADCP, but not when these data + discharge are being recorded for a 

transect measurement.   

• The transect start/end points must be located where a minimum of 2 Good Bins can be 

measured along the transect. Measurement quality increases the closer the two locations are to 

areas with 2 Good Bins.  

o Uncertainty associated with the discharge measurement increases as the distance 

increases between the transect start and end points and the edges of water.  

• In channels that contain vertical walls at the edges, transect start and end points should be no 

closer to the wall than the depth of water at the wall to prevent acoustic interference from the 

main beam or side lobes impinging on the wall.  

o For example, if the depth at a vertical wall is 10 feet, transects should start or stop at least 

10 feet away from the wall. 
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To establish transect start and end points: 

1. In the WinRiver II main screen, select “Acquire” > “Start Pinging”. 

a. This means that the ADCP is collecting data, but not recording data. The ADCP can be 

left in this state throughout the measurement, just be aware of battery voltage. Later, 

when collecting transect measurements, the ADCP will be placed into data recording 

mode. 

2. Navigate the ADCP just past the edge of water on the near shore and into open water until the 

ADCP transducers are submerged. 

3. Slowly move the ADCP away from the near bank until the number of “Good Bins” in the 

“Composite Tabular” window (Figure 10) is > 2 (the closer the transect start point can be at 2 

Good Bins, the better). This is the first transect start/end point.  

4. If possible, mark this location with a clip on the tagline (during trimaran float deployments), a 

weighted buoy or marked float (during ARC-Boat or Piloted Boat deployments, or otherwise try 

to remember the location based on a physical reference.  

5. Navigate the ADCP slowly to the opposite shore.  

a. This is a good opportunity to assess ADCP functionality and channel conditions by 

viewing profile data in the Velocity Contour graph at the bottom of the WinRiver II 

screen.  

6. As the ADCP approaches the edge of water at opposite shore, note the “Number of Good Bins” 

in the “Composite Tabular” window (Figure 10) and stop the ADCP at the opposite edge of 

water at the last location where 2 Good Bins are available. This is the second transect start/end 

point.   

7. If possible, mark this location in the same manner as the first transect start/end point.  
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Figure 10. Composite Tabular window in WinRiver II, green box: number of ensembles (hold until 10 at transect 
start/end points); red box: Number of Good Bins (must be >2 to begin transect and should be near 2 to end 
transect); purple box: total discharge; blue boxes: water and boat speed; orange box: distance made good (total 
transect length); brown box: duration (total transect duration must be ≥180 seconds). 

B.9 Collecting Transect Discharge Measurements 

A discharge transect measurement is considered a single ADCP discharge measurement that begins at 

one of the designated transect start/end points and ends at the other (a one-time pass across the 

channel). Discharge data is recorded during each transect measurement and the total measured 

discharge associated with the bout is the average of the discharge calculated during each transect 

measurement. 

Some notes on ADCP transect measurements: 

• ADCP discharge measurements must contain reciprocal pairs; or an even number of transect 

measurements, with half starting from the right bank and half starting from the left bank.  

• A minimum of four transect measurements are required for each ADCP discharge measurement 

but additional transect measurements may be required.  

• Each transect measurement must last a minimum of 180 seconds and total time for all transects 

measurements must be >720 seconds.   

• A new data file and Transect node will be created in under “Site Discharge” in the 

“Measurement Ctrl” window for each transect measurement.  (ex: Transect 0000, Transect 001, 

Transect 002, Transect 003).   
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o Data collected during a given transect measurement can be evaluated by double-clicking 

on the disc icon under the Transect node of interest.  

• Transect measurements are to begin only after the ADCP has been configured, pre-

measurement QAQC procedures have been conducted, and transect start/end points have been 

delineated.  

To collect transect measurements: 

1. Enter the staff gauge height in Discharge app prior to each transect measurement.  

2. Place the ADCP in the water at a transect start/end point. The measurement typically begins at 

the near shore but can start from either bank.  

3. Using a measuring device such as a meter tape or a laser rangefinder, measure the distance 

from the center of the ADCP to the edge of the water. This is referred to as the “edge distance”.  

a. If it is not possible to physically measure the edge distance, the “Distance MG [Made 

Good]” values displayed on the right side of the “Composite Tabular 1” window (Figure 

10) can be used to determine this measurement.  

b. The edge distance does not need to be re-measured if this transect start/end point is 

used for each transect measurement.   

c. Channel edges are one of three unmeasured areas of the ADCP profile where velocity is 

extrapolated (Figure 11).  

4. To start the transect measurement and begin data recording, select “Acquire” > “Start 

Transect”.  

5. When prompted, enter the edge distance and define whether the transect measurement is 

starting from the left or right bank (looking downstream).  

6. Hold the position of the ADCP steady at the transect start/end point for at least 10 seconds 

(avoid as much movement as possible during this period). 

7. Once 10 seconds have elapsed, begin to move the ADCP slowly and steadily across the channel 

toward the opposite bank. 

a. The duration of each transect measurement must be ≥ 180 seconds. 

b. Data quality improves with slow, steady, and smooth navigation across the channel. 

Avoid sudden acceleration. If possible, maintain a speed that is less than the water 

velocity.   

c. For ARC-Boat or Piloted Boat deployments, point the bow of the boat upstream and 

crab slowly across the channel. 

8. Continue across the channel until the ADCP reaches the far shore transect start/end point. 
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9. Hold the position of the ADCP at the transect start/end point for at least 10 seconds (avoid as 

much movement as possible during this period). 

10. Using a measuring device such as a meter tape or a laser rangefinder, measure the distance 

from the center of the ADCP to the end of the water to determine the second edge distance.  

a. The edge distance does not need to be re-measured if this transect start/end point is 

used for each transect measurement.   

11. To end the transect measurement and cease data recording, select “Acquire” > “Stop Transect”.  

12. When prompted, enter the edge distance and define whether the transect measurement ended 

at the left of right bank (looking downstream).  

13. To add any notes associated with the transect measurement, right click on the transect node 

under “Site Discharge” in the “MeasurementCtrl” window and select “Add Note”.  

a. Transect notes are critical to document important information needed to evaluate 

individual transect discharge values and whether they should be included or excluded in 

the total measurement during post-processing.   

b. A note is required if a transect measurement should not be used (for whatever reason) 

in the discharge calculation. 

14. The first transect measurement is now complete. 

15. Collect, at minimum, three additional transect measurements. Repeating the steps above to 

navigate the ADCP back and forth from one transect start/end point to the other.   

a. A minimum of four transect measurements (each lasting ≥ 180 seconds) must be 

collected during each discharge measurement, two starting from the left bank and two 

starting from the right bank.  

b. If additional transect measurements are collected, they must be in reciprocal pairs (one 

that begins from the right bank and one that begins from the left bank).  

16. Once four transect measurements have been collected, reference Table 6 and continue onto the 

next set of steps to evaluate whether additional measurements are required. 

17. If GPS data was enabled, transect locations can be saved and used during future measurements 

following the steps listed in Appendix D.  
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Figure 11. Unmeasured areas in the ADCP profile where velocity is extrapolated. Top left: ADCP blanking distance 
and cell size distribution; top right: unmeasured areas of the profile relative to ADCP beams (credit: SonTek); 
below: a velocity contour profile graph in WinRiver II with unmeasured areas delineated. Channel edges are not 
shown but constitute the third unmeasured area along with the top and bottom of the channel.  

Table 6. Conditions to evaluate whether additional transect measurements are needed during the ADCP discharge 
measurement. 

Condition 
Additional 
Measurement 
Transects Needed? 

Details 

Individual transect 
duration < 180 
seconds 

Yes 
Collect additional reciprocal transect measurements 
that are >180 seconds. 

Total measurement 
duration  
< 720 seconds 

Yes 
Collect additional reciprocal transect measurements 
that are >180 seconds so that the total duration of all 
transects is >720 seconds.  

Fluctuating stage 
levels during 
measurement? 

Maybe 
Consider collecting additional reciprocal transect 
measurements if changing stage levels resulted in 
notable differences in transect discharge totals.   

Suspicious Total Q, 
Average Q, or Delta 
Q values? 

Maybe  

If the average discharge value is suspicious or if transect 
discharge totals are not well-related given site/flow 
conditions, consider collecting additional reciprocal 
transect measurements. 

 

To evaluate whether more transect discharge measurements are needed: 

1. In the “Measurement Ctrl window” ensure that each transect measurement you wish to 

evaluate is checked.   
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a. Uncheck any transect measurements that contain errors and are not meant to be 

included in the evaluation. 

2. Hit the F12 button to produce the “Discharge Summary” table which provides information on 

each transect measurement. 

3. Review the “Duration” values for each transect measurement. Ensure each are ≥ 180 seconds 

and the sum of all transect duration is ≥ 720 seconds. 

a. If either of these requirements are not met, conduct additional reciprocal transect 

measurements.  

4. Review the “Total Q” and “Delta Q” values for each transect measurement, and the “Average” 

value for all transect measurements.  

a. The “Total Q” value is the total measured discharge during the transect measurement. 

b. The “Delta Q” value is the percent difference of discharge for the transect measurement 

relative to the average discharge across all transect measurements (Figure 12).  

i. Ideally, all transect measurements contain a Delta Q value that is 5-10% (these 

can be positive or negative percentages) in small streams and < 5% (positive or 

negative) in larger rivers.  

ii. These requirements can be difficult to obtain when measuring discharge in small 

streams, during low-flow regimes, and during periods of changing hydrologic 

conditions. 

c. The “Average” is the average discharge of all transect measurement discharges.  

d. Use your knowledge of the stream (is this a reasonable discharge estimate at this stage 

level?), information contained in the stage-discharge rating curve (what is the discharge 

+/- uncertainty that the model predicts at this stage level?), and an overall assessment 

of the quality of the ADCP measurement (was data quality as high as to be expected?) to 

determine if these values are acceptable or if additional transect measurements are 

needed. 

e. Typically, data quality typically improves, and the uncertainty associated with the 

estimated measurement decreases as additional transect measurements are included in 

the discharge bout. If measurement quality is in doubt, it is best practice to collect 

additional reciprocal transect measurements.   
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Figure 12. Discharge summary window in WinRiver II. The red box highlights Delta Q values. In this example all are 
< 5%, an indication that no additional transect measurements are required. 
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SOP C Evaluating the Discharge Measurement in the Field Using WinRiver II and Q-Rev Software 

Following the discharge survey, the measurement file must be evaluated both in the field prior to 

leaving the site and once again in the office during post-processing and upload. In addition to impacts to 

data quality, certain errors in the discharge file will prevent the file from being uploaded.  WinRiver II 

files contains metadata and measurement data that are read into Q-Rev software which calculates 

additional metrics. The published measurement file contains values derived from both software 

programs, thus is it critical that both WinRiver II and Q-Rev data are thoroughly reviewed.   

The following criteria must be checked prior to leaving the field site: 

• Review, finalize, and save data in WinRiver II. 

• Review, finalize, and save data in Q-Rev. 

To review, finalize, and save data in WinRiver II: 

1. Playback each measured transect.  

a. In the “Measurement Ctrl window” ensure that each transect measurement you wish to 

evaluate is checked.   

i. Uncheck any transect measurements that contain errors and are not meant to be 

included in the evaluation. 

b. Select “Playback” > “Reprocess Checked Transects”. 

2. Open each Transect node in the “MeasurementCtrl” window and double click on “Playback 

Configuration”. 

a. In the window that opens select the “Edge Estimates” node under “Properties” on the 

left. 

i. Ensure that “Shore Distance [m]” values under “Begin Transect” and “End 

Transect” are correct. These are the edge distances that were measured for each 

transect in SOP B.9. 

b. Select the “Offsets” node under “Properties” on the left. 

i. Ensure the “ADCP Transducer Depth” value is correct. This is transducer depth 

measured in SOP B.1. 

c. Once any value has been entered in the “Playback Configuration” window, the value can 

be applied to all selected transects by right clicking on the value in the box and selecting 

“Apply to All Active Configurations”. All transects will need to be played back for this 

change to be implemented.  

3. Ensure that all metadata were entered correctly in the “Site Information” window, particularly 

“Field Party”, “Water Temp”, “Wind Direction” and “Wind Speed”.  
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4. Enter all applicable notes in the Remarks section of the “Site Information” window and in 

individual transect notes, as necessary. 

5. Following data review, save the measurement file on the laptop and on USB flash drive for 

backup.  

a. An .MMT file will be created along with .PDO files that are unique to individual 

transects.  Each of these files must be saved as they are needed for post-processing and 

uploading.  

To review, finalize, and save data in Q-Rev: 

1.  Run the Q-Rev software and select the folder icon on the top left to open the .mmt file that was 

just saved in WinRiver II. Remember that the location where the .mmt file is saved must also 

contain the corresponding .PDO files (transect data), or the measurement cannot be viewed in 

Q-Rev. 

a. When prompted “Do you want to load ONLY checked transects?”, select “No” so that all 

transects are loaded.   

2. Once the .mmt file is loaded, note the check mark icon at the top of the screen.  

a. A green color indicates that all transects are included in the measurement calculation. 

An orange indicates that one or more transects are not included.   

b. Select the check mark to include or exclude certain transects, if needed. 

3. Under the “Main” tab, the “Summary” tab will display a summary table.  

a. Check the “Total Q (m3/s)” (total discharge) value along with the “Estimated 95%” (total 

uncertainty) value in the table to the right of the screen. 

b. Ensure that both values are acceptable.  If not acceptable, select different transects to 

include/exclude in the measurement or collect additional discharge transects in the 

field.  

4. Quickly review the color of each tab at the top of the screen and investigate any attributes that 

are yellow or red.     

a. Each tab represents a unique attribute of the discharge measurement with the color of 

the tab indication the data quality.    

i. Green: High quality, no investigation required. 

ii. Yellow: Issues may be present and could require corrective action, investigation is 

required. 

iii. Red: Issues are present that negatively affect the measurement, investigation is 

required. 
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b. Table 7 provides details on each attribute evaluated by Q-Rev with suggested 

troubleshooting steps. Reference the Q-Rev user guide for additional information on 

how attributes are calculated and evaluated. 

5. Make any necessary edits and collect additional transect measurements as needed following 

field review of Q-Rev data. Once field verification is complete, save the file and exit Q-Rev.  

a. Saving will produce an .xml and a .mat file. Both are required for post-processing and 

should be saved in the same location as the WinRiver II files.  

Table 7. Descriptions and troubleshooting suggestions for attribute tabs listed in the Q-Rev software. 

Q-Rev tab Description Troubleshooting  

Main 

Contains important 
summary information, 
individual transect details, 
and ADCP settings  

Review all data contained in this tab, particularly Total Q, 
Duration, Delta Q and Edge Distance per transect, and pre-
measurement QAQC metadata. Some pre-measurement 
QAQC metadata can be edited here, others must be edited 
in other Q-Rev tabs or WinRiver II. Total Q will change as  
different transects are selected for inclusion in Q-Rev, 
additional transect measurements are collected in the 
field.   

SysTest 
Contains information on 
the ADCP diagnostic test 

Review test results, ensuring that the diagnostic test was 
completed all tests passed. 

Compass/P/R 
Contains information on 
the compass calibration 
test and boat pitch/roll 

Tab will be yellow if compass calibration error is >1 degree, 
red if > 2 degrees. Magnetic variation, Heading Offsets, 
and Heading Source values can be edited by clicking on the 
values in the “Data” tab. 

Temp/Sal 
Contains information on 
temperature, salinity, and 
speed of sound data 

Review the Water Temperature timeseries which displays 
ADCP temperature over the course of all checked 
transects. Drift can be attributed to inadequate time for 
equilibration or actual changes in water temperature.  The 
Independent temperature can be edited in the box on the 
bottom left.  

MovBedTest 
Contains information on 
the moving bed test(s) 

Assess Ship Track data and boat speed, ensuring that the 
“User Valid” and “Used for Correction” boxes are properly 
selected. If the “User for Correction” box is selected, the 
total measured discharge value will change.  

BT 
Contains information on 
bottom tracking per 
transect 

Note the values % Invalid columns, the tab will turn yellow 
or red based as these percentages increase.  Timeseries 
data on the upper graph indicates where bottom tracking 
errors occurred (number of beams = 0) across each 
transect.  
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Q-Rev tab Description Troubleshooting  

GPS 
Contains information on 
GPS data, if available 

Note the values % Invalid columns, the tab will turn yellow 
or red as these percentages increase.  Timeseries data 
indicates the correlation between GPS and BT streams and 
where GPS errors occurred (GGA/VTG quality = 0) across 
each transect.  

WT 
Contains information on 
water track data per 
transect 

Note the percentage of depth cells that have been 
determined to be invalid by the various filters and the 
effect of a filter change on the computed discharge. Cells 
in the table contain color codes associated with cautions or 
warnings. No editable cells are in this table. 

Extrap 

Contains information on 
ADCP extrapolation, or 
how discharge is 
computed in the 
unmeasured areas of the 
channel 

The graph shows the normalized discharge or velocity in 
each depth cell for all transects with the dark black line 
displaying the extrapolation fit for the composite 
measurement. The exponents derived from the fit are used 
to calculate the top and bottom unmeasured discharge. 
These settings are not typically adjusted. 

Edges 
Contains information on 
edge discharge 
computations 

Ensure that the Left and Right Dist. Values are correct 
(these are the edge distances per transect) and adjust by 
clicking on the values, if needed. Note the Left and Right 
%Q values, this is the percentage of discharge calculated 
from each edge - the tab will turn yellow or red as these 
percentages increase and/or as excessive boat movement 
increases in the left/right edge ensembles.    

EDI 

Allows the user to select 
transects for use in equal-
discharge sediment and 
water quality sampling 

No review needed, as this functionality is not currently 
utilized 

Adv. Graph 
Allows the user to create 
plots based on specific 
discharge parameters 

This function can be used to view multiple datasets 
simultaneously on stacked plots.  
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SOP D Document Incomplete Sampling Within a Site 

Incomplete sampling documentation for the Configurations, Settings, and Collections Methods for 

Stream Discharge Measurements Using the ADCP Method SOP is identical to that described in RD(04). 

Consult the protocol for this workflow.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



 

Title: AOS Standard Operating Procedure: DSC – Configurations, Settings, and Collection 
Methods for Stream Discharge Measurements using the ADCP Method 

Date: 05/14/2024 

NEON Doc. #: NEON.DOC.005389 Author: N. Harrison Revision: A 

 

SOP E 
 

Page 42 

SOP E Data Entry, Verification, and Post-Processing  

Data Entry, Verification, and Post-Processing procedures for Stream Discharge Measurements Using the 

ADCP Method SOP is identical to that described in RD(04). Consult the protocol for this workflow.    
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APPENDIX A REMINDERS 

Always remember to:  

• Have fresh batteries in the ADCP.  

o Low batteries can result in poor bottom tracking and/or communication failures between 

the instrument and the laptop. 

• Document relevant notes that pertain to the discharge measurement in the Remarks section of 

WinRiver II.  

o Notes may include changes in discharge measurement location, changes in reference 

navigation, issues with specific transects, pre-measurement QAQC notes, or 

environmental factors that may have affected the discharge measurement. Include 

anything you would want the end user to know about the measurement when reviewing 

the file.  
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APPENDIX B EQUIPMENT 

The following equipment is needed to implement the procedures in this document. Equipment lists are 

organized by task. They do not include standard field and laboratory supplies such as charging stations, 

first aid kits, drying ovens, ultra-low refrigerators, etc. 

Table 8. Equipment list – ADCP Discharge Measurements.  

Supplier/ 
Item No. 

Exact 
Brand 

Description Purpose 
Quan-
tity 

 N 
Fully charged laptop with Bluetooth 
capability and necessary software 
installed (WinRiver II, Q-Rev, ParaniWin) 

Interfaces with ADCP and GPS (all 
deployment types) 

1 

Sena Y Parani SD1000U Bluetooth transmitter 
Transmits ADCP and GPS data from 
instruments to laptop via Bluetooth 
connection (all deployment types) 

3 

Teledyne Y 
StreamPro ADCP with 8 charged AA 
batteries 

Measures discharge (trimaran float 
deployments only) 

1 

Teledyne Y 
RiverPro ADCP with 8 charged AA 
batteries 

Measures discharge (remoted 
controlled and piloted boat deployment 
types only) 

1 

 N Charged RiverPro ADCP 12V batteries 
Powers the ADCP (remote controlled 
and piloted boat deployment types 
only) 

2 

H.R. 
Wallingford 

Y Charged ARC-Boat Batteries (10Nimh) 
Powers the ARC-Boat (remote 
controlled deployments only) 

4 

H.R. 
Wallingford 

Y Charger for ARC-Boat batteries 
Charges ARC-Boat batteries (remote 
controlled deployments only) 

1 

H.R. 
Wallingford 

Y 
Charged ARC-Boat Remote Control 
(Futaba 2.4GHz) w/neckstrap and 
charged battery pack 

Controls the ARC-Boat (remote 
controlled deployments only) 

 

H.R. 
Wallingford 

Y 
Spare ARC-Boat Remote Control battery 
pack 

Powers the ARC-Boat remote controller 
(remote controlled deployments only) 

 

SX Blue Y SX Blue GPS antenna 
Provides GPS data during discharge 
measurement (trimaran float 
deployments only) 

1 
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Supplier/ 
Item No. 

Exact 
Brand 

Description Purpose 
Quan-
tity 

Hemisphere Y Hemisphere GNSS V102 GPS antenna 
Provides GPS data during discharge 
measurement (remoted controlled and 
piloted boat deployment types only) 

 

H.R. 
Wallingford 

Y 
RiverPro ADCP Adapter for ARC-Boat 
(with charged 12V battery inside) and 
GPS mount 

Houses ADCP in ARC-Boat, provides 
ADCP power and Bluetooth 
communications (remote controlled 
deployments only) 

1 

Teledyne Y 
Trimaran float and all associated 
components to mount ADCP and GPS 
units 

Deploys the StreamPro ADCP and SX 
Blue GPS (trimaran float deployments 
only) 

1 

ECO-05389 Y 
ADCP mount (all components listed in 
ECO-05389) + Allen wrench 

Deploys RiverPro ADCP over the side of 
the piloted boat (piloted boat 
deployment types only) 

1 

H.R. 
Wallingford 

Y ARC-Boat  
Deploys River Pro ADCP (remote 
controlled deployments only) 

1 

H.R. 
Wallingford 

Y 
ARC-Boat spare parts kit with Allen 
wrench 

ARC-Boat maintenance (remote 
controlled deployments only) 

 

 N Anchored floats (non-magnetic) 
Marks transect start and end points 
(remote controlled and piloted boat 
deployment types only) 

2 

Teledyne N 

Temporary High Line – all components 
(tripod, winch post, pulley post, 
Guideline rope, guideline support, guy 
wire + earth anchor, guy wire driving 
rod) 

Mechanical assembly used to deploy the 
trimaran float across the stream channel 
(trimaran float deployments only) 

1 

 N 

Control rope (minimum length is twice 
the wetted width of the stream + 
additional length to accommodate the 
distance to the point of operation on 
the near bank and tie off on the far 
bank, strong climbing rope is 
recommended) 

Long length of rope used to pull the 
trimaran float back and forth across 
channel (trimaran float deployments 
only) 

1 

 N 

Trimaran rope (required length is 
dependent on surface velocity during 
the measurement, maximum length not 
likely to exceed ~1.5m, strong climbing 
rope is recommended) 

Short length of rope that connects and 
orients the trimaran float to the 
Guideline rope (trimaran float 
deployments only) 

1 
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Supplier/ 
Item No. 

Exact 
Brand 

Description Purpose 
Quan-
tity 

 N Locking carabiner 
Connects the trimaran float to the 
Trimaran rope (trimaran float 
deployments only) 

3 

 N Small hammer or mallet 

Drives the guy wire earth anchor into 
the substrate to support High Line 
assembly (trimaran float deployments 
only) 

1 

 N Thermometer (reads in C) 
Measures water temperature (all 
deployment types) 

1 

 N Anemometer (reads in kmh) 
Measures wind speed (all deployment 
types) 

1 

 N Laser rangefinder 
Measures edge distances (all 
deployment types) 

1 

 N Meter tape or metric ruler 
Measures ADCP depth and edge 
distances (all deployment types) 

1 

 N Flagging 
Marks start and end transect points (all 
deployment types) 

1 

 N Sharpie Marks flagging (all deployment types) 1 

 N Laptop cover or umbrella 
Protects laptop in wet weather (all 
deployment types) 

1 

 N Lazy Susan (contains no magnetic parts) 
Rotates ADCP during pre-measurement 
QAQC, reduces compass calibration 
error (all deployment types) 

1 

 N Laptop shade 
Shades computer screen so it can be 
easily read in bright weather (all 
deployment types) 

1 

 N USB flash drive 
Backs up measurement files (all 
deployment types) 

1 

 NA 
Discharge protocol and laminated TRDI 
protocol cards 

Used as a reference during discharge 
measurement (all deployment types) 

1 

 NA All necessary safety and PPO Safety (all deployment types) NA 
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APPENDIX C APPLYING GPS EXTERNAL HEADING OFFSETS 

When GPS data are available, the GPS antenna is considered an external heading, i.e. the internal ADCP 

heading is not being used. When an External Heading is applied, the Bottom Track reference assumes 

the External Heading device is aligned with Beam 3 of the ADCP. Therefore the Bottom Track reference 

is directly affected by the relationship between the GPS heading and the ADCP heading. The GPS 

antenna is not required to face towards the bow of the boat, but it must be aligned with the ADCP Beam 

3 (see RD[04] for details on installing GPS antennas during ADCP measurements) .   

If the GPS antenna is not aligned with the ADCP Beam 3, a heading offset must be entered to align the 

External Heading and Bottom Track Ship Tracks in the WinRiver II settings (Figure 13). This can be done 

prior to the transect measurement in the Field Configuration Settings or following the transect 

measurement in the Playback Configuration settings.    

To enter an External Heading offset after transects have been measured: 

1. Open the Transect node. 

2. Select “Playback Configuration”. 

3. Open the “DS/GPS/EH” tab. 

4. Under the “External Heading” section, enter a Heading Offset value (i.e. “45” if the GPS is at a 45 

degree angle relative to Beam 3 of the ADCP). 

5. Right click on the value to apply to all transects (if required). 

6. Playback the transect to apply the offset. 
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Figure 13. Applying External Heading offsets to align GPS and Bottom Track Ship Tracks. 
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APPENDIX D CREATING TRANSECT LOCATION FILES 

Location files use GPS data to save the location of transect start and end points so that they can be 

utilized during subsequent discharge surveys. This feature cannot be utilized if GPS data was not 

integrated into the measurement. After a transect has been measured, it appears in the WinRiver II 

Measurement Control window, and the location can now be saved. Multiple transect locations can be 

saved using unique files names. 

To create a Transect Location file: 

1. Complete a discharge measurement at the transect where you would like to save the location 

for future use (the measurement must contain GPS data). 

2. In the Measurement Ctrl window, right-click on the transect node and select “Define Transect 

Location” (Figure 14). 

3. The “Edit Locations” window will appear. Click on the cross-hairs on the map to broadly zoom in 

on the transect location.   

4. Enter a Location Name and add any relevant notes about the transect.  

5. Click the “Save & Close” button and select “Save” on the “Save Location” screen to create the 

location file. 

6. The *.dat location file will be saved to the C:\Measurements\Locations folder by default (the file 

location can be edited).     

7. Location files will automatically be used in future measurements if the transect is within 100m 

of the locations specified in the file. You may need to manually scale the Ship Track display in 

order for the location line to be visible in the display (Figure 15). GPS data must be enabled for 

the saved transect location to appear.  

 

 
Figure 14. Defining transect locations In WinRiver II. 



 

Title: AOS Standard Operating Procedure: DSC – Configurations, Settings, and Collection 
Methods for Stream Discharge Measurements using the ADCP Method 

Date: 05/14/2024 

NEON Doc. #: NEON.DOC.005389 Author: N. Harrison Revision: A 

 

 
 

Page 51 

 
Figure 15. The Stick Ship Track window with the line of the transect (red) displayed alongside the line of the saved 
transect location (black) and velocity vectors (blue). 
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